aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commitefeb47c83b3b7ce1f03fda581c1c8a8e5c132e6b (patch)
treeb0f049d6c1689e708ef45977830a2c2dcf430f0a
parent462e0825d14628848653b2b7a80112f2501225df (diff)
downloadguix-efeb47c83b3b7ce1f03fda581c1c8a8e5c132e6b.tar
guix-efeb47c83b3b7ce1f03fda581c1c8a8e5c132e6b.tar.gz
gnu: Add ruby-kgio.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5ac187c324..b3edf008bf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8519,3 +8519,30 @@ but it can function as a stand-alone templating engine.")
"Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
(home-page "http://github.com/alexch/rerun/")
(license license:expat)))
+
+(define-public ruby-kgio
+ (package
+ (name "ruby-kgio")
+ (version "2.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "kgio" version))
+ (sha256
+ (base32
+ "1528pyj1szzzp3pgj05fzjd36qjrxm9yj2x5radc9p1z7vl67y50"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (description
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (home-page "https://bogomips.org/kgio/")
+ (license #f)))