aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:36 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commitbf81ae1cf0300eebedb606d79f1bd7c8f34ff1b5 (patch)
tree5ad8f4b7cae9944c70d148117992517a3e99a831
parentb4549bd28356c3ee8d524c8aaf3244ba411042fd (diff)
downloadguix-bf81ae1cf0300eebedb606d79f1bd7c8f34ff1b5.tar
guix-bf81ae1cf0300eebedb606d79f1bd7c8f34ff1b5.tar.gz
gnu: Add ruby-unicorn.
-rw-r--r--gnu/packages/web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c4b78d0b64..1d8565b8c3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -55,6 +55,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system ruby)
#:use-module (guix build-system cmake)
#:use-module (guix build-system r)
#:use-module (guix build-system trivial)
@@ -110,6 +111,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml)
#:use-module (gnu packages curl)
@@ -6680,3 +6682,33 @@ compressed JSON header blocks.
provided by Guix. The list of packages is searchable and provides
instructions on how to use Guix in a shared HPC environment.")
(license l:agpl3+))))
+
+(define-public ruby-unicorn
+ (package
+ (name "ruby-unicorn")
+ (version "5.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicorn" version))
+ (sha256
+ (base32
+ "09s3mdsrc080h7b70lkl2wnv36iy9ipdqbi1ffm3fxd0498xjb7h"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-kgio" ,ruby-kgio)
+ ("ruby-raindrops" ,ruby-raindrops)))
+ (synopsis
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (description
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (home-page "https://bogomips.org/unicorn/")
+ (license (list #f #f))))