aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:19:16 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit97487793d4884a3db841786dcd768c45a419c308 (patch)
tree99f1142448fc222d7db8b205de9fdc5cb5b21f12
parent807f1d0f54a26556eb1351a3ad2e73f07b9185c2 (diff)
downloadguix-97487793d4884a3db841786dcd768c45a419c308.tar
guix-97487793d4884a3db841786dcd768c45a419c308.tar.gz
gnu: Add ruby-annotate.
-rw-r--r--gnu/packages/rails.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index e84c1cde68..6df15ad619 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -616,3 +616,37 @@ API.")
(description "Squash your old migrations")
(home-page "https://github.com/jalkoby/squasher")
(license license:expat)))
+
+(define-public ruby-annotate
+ (package
+ (name "ruby-annotate")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "annotate" version))
+ (sha256
+ (base32
+ "079y33iy65nv1cqnh1zmi3v2y9yp1z3zzsf2wdh35m3c80v6kaz4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-annotate
+ (lambda _
+ (substitute* "bin/annotate"
+ (("require 'bundler'")
+ "")
+ (("Bundler.setup")
+ "")))))))
+ (propagated-inputs
+ `(("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (description
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (home-page
+ "http://github.com/ctran/annotate_models")
+ (license #f)))