aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:21 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit86f059c28b861a3b7b3f9778648e9c76fafd0301 (patch)
treef3031e2c9233b39b26ab5b044d361cb91e0b92ea
parent40d202ce30754561e80fcd6f2555798f12bd2cc2 (diff)
downloadguix-86f059c28b861a3b7b3f9778648e9c76fafd0301.tar
guix-86f059c28b861a3b7b3f9778648e9c76fafd0301.tar.gz
gnu: Add ruby-hamster.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a7c7733637..49567226b6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8166,3 +8166,27 @@ but it can function as a stand-alone templating engine.")
"open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
(home-page "https://github.com/ahoward/open4")
(license #f)))
+
+(define-public ruby-hamster
+ (package
+ (name "ruby-hamster")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hamster" version))
+ (sha256
+ (base32
+ "1n1lsh96vnyc1pnzyd30f9prcsclmvmkdb3nm5aahnyizyiy6lar"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (description
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (home-page
+ "https://github.com/hamstergem/hamster")
+ (license license:expat)))