aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit7b64f95e157af2284bf5467f9215f050eb8434c1 (patch)
tree437e0a950866ac717f8efa340d95d543dbb019ab
parent2e427fbe31276392be399b338985229cc998fe99 (diff)
downloadguix-7b64f95e157af2284bf5467f9215f050eb8434c1.tar
guix-7b64f95e157af2284bf5467f9215f050eb8434c1.tar.gz
gnu: Add ruby-event-bus.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 80aba70c49..73aefce73f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1361,6 +1361,34 @@ support.")
(home-page "https://github.com/rails/execjs")
(license license:expat)))
+(define-public ruby-event-bus
+ (package
+ (name "ruby-event-bus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "event-bus" version))
+ (sha256
+ (base32
+ "0bqcznr15q1346avpddnyd9144hqdww86yfpb4jayaj6lm0fqwyq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; disable testing to break the cycle with aruba. Instead simply test that
+ ;; the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "event/bus")))))))
+ (synopsis
+ "This gem notifies subscribers about event")
+ (description
+ "This gem notifies subscribers about event")
+ (home-page
+ "https://github.com/cucumber/event-bus")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")