aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:15:31 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit5cae74415608a9be1cd0824012604cfba305f74e (patch)
treed01d00395f77ea8f244ca74cfe6a919961b92f9f
parenta88c55bfeea4d503d67c801324e7d8c1f7a011f6 (diff)
downloadguix-5cae74415608a9be1cd0824012604cfba305f74e.tar
guix-5cae74415608a9be1cd0824012604cfba305f74e.tar.gz
gnu: Add ruby-ref.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 28d88eaa99..b9f3d14573 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7036,3 +7036,33 @@ way.")
(home-page
"http://github.com/rails/ruby-coffee-script")
(license license:expat)))
+
+(define-public ruby-ref
+ (package
+ (name "ruby-ref")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/ruby-concurrency/ref/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1090z8vzf8bf7gx3akvrn4alcklyanbg6hipjmzlzkx0lr1l5zj4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (synopsis
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes implementation
+of maps/hashes that use references and a reference queue.")
+ (description
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes
+implementation of maps/hashes that use references and a reference queue.")
+ (home-page
+ "http://github.com/ruby-concurrency/ref")
+ (license license:expat)))