aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:50:51 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit5a699e62d4fe2ba3a62828d302ffbef3545fa405 (patch)
treee178df5b392956df2415223651707404d616df94
parent1f12dd09d59307fc9cf5251647e7b7df00e5b7a3 (diff)
downloadguix-5a699e62d4fe2ba3a62828d302ffbef3545fa405.tar
guix-5a699e62d4fe2ba3a62828d302ffbef3545fa405.tar.gz
gnu: Add ruby-launchy.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7f7af8bc33..4a28c1a9e4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7989,3 +7989,25 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/lostisland/faraday_middleware")
(license license:expat)))
+
+(define-public ruby-launchy
+ (package
+ (name "ruby-launchy")
+ (version "2.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "launchy" version))
+ (sha256
+ (base32
+ "190lfbiy1vwxhbgn4nl4dcbzxvm049jwc158r2x7kq3g5khjrxa2"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)))
+ (synopsis
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (description
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (home-page
+ "http://github.com/copiousfreetime/launchy")
+ (license #f)))