aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:12 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit40d202ce30754561e80fcd6f2555798f12bd2cc2 (patch)
treee94e0e30dd470e58e9ff98eb2c98817f90e3fa15
parentfc7718b843f66f2559c9e007b14c90a0d7aa86cc (diff)
downloadguix-40d202ce30754561e80fcd6f2555798f12bd2cc2.tar
guix-40d202ce30754561e80fcd6f2555798f12bd2cc2.tar.gz
gnu: Add ruby-open4.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 26f5f77496..a7c7733637 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8145,3 +8145,24 @@ but it can function as a stand-alone templating engine.")
"")
(home-page "")
(license license:expat)))) ;?
+
+(define-public ruby-open4
+ (package
+ (name "ruby-open4")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "open4" version))
+ (sha256
+ (base32
+ "1cgls3f9dlrpil846q0w7h66vsc33jqn84nql4gcqkk221rh7px1"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (description
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (home-page "https://github.com/ahoward/open4")
+ (license #f)))