aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-14 08:01:12 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit351826dc1cc24e64ecdff6f871e9cce467790fc4 (patch)
treeb4da98c1030c0f388b0efeec3cd7da698d4bcd48
parent0c4dbc9818d80d87178e772c19da657c2cbdb1b3 (diff)
downloadguix-351826dc1cc24e64ecdff6f871e9cce467790fc4.tar
guix-351826dc1cc24e64ecdff6f871e9cce467790fc4.tar.gz
gnu: Add ruby-prometheus-client.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7aa5a5ca57..fc85b9d355 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8612,3 +8612,25 @@ counters across multiple processes.")
(home-page
"http://github.com/matttproud/ruby_quantile_estimation")
(license license:asl2.0)))
+
+(define-public ruby-prometheus-client
+ (package
+ (name "ruby-prometheus-client")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prometheus-client" version))
+ (sha256
+ (base32
+ "0ihbmnll7qkkhy5isd7vl3wrznyxm1havhzxhl8729im5qi6si51"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-quantile" ,ruby-quantile)))
+ (synopsis
+ "A suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (description
+ "This package provides a suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (home-page
+ "https://github.com/prometheus/client_ruby")
+ (license license:asl2.0)))