aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:33 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit0a1b28525b58e358001dd55f68aecad7e9489e11 (patch)
tree7ee62450be24a169d5fb84d65e5a5b6f4cdaea7a
parentd9336ebec3c0667c5c6a35148354f95ecd30180f (diff)
downloadguix-0a1b28525b58e358001dd55f68aecad7e9489e11.tar
guix-0a1b28525b58e358001dd55f68aecad7e9489e11.tar.gz
gnu: Add ruby-oauth2.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fc9243b929..0f52cced86 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8400,3 +8400,30 @@ but it can function as a stand-alone templating engine.")
"This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
(home-page "http://github.com/jwt/ruby-jwt")
(license license:expat)))
+
+(define-public ruby-oauth2
+ (package
+ (name "ruby-oauth2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oauth2" version))
+ (sha256
+ (base32
+ "094hmmfms8vpm6nwglpl7jmlv85nlfzl0kik4fizgx1rg70a6mr5"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-jwt" ,ruby-jwt)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-multi-xml" ,ruby-multi-xml)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (description
+ "This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (home-page "http://github.com/intridea/oauth2")
+ (license license:expat)))