aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:02:11 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commit0782807882d9a05e29ccf1ec293669f2920342c9 (patch)
tree7f46adb5fdc8104da0466573a7fddbf31c0ad2d6
parentdd8ee66aa520227f6850721ba9ac77cc48db11d8 (diff)
downloadguix-0782807882d9a05e29ccf1ec293669f2920342c9.tar
guix-0782807882d9a05e29ccf1ec293669f2920342c9.tar.gz
gnu: Add ruby-listen-3.0.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch16
-rw-r--r--gnu/packages/ruby.scm18
3 files changed, 35 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 76ab50fd17..77b3575f4a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1123,6 +1123,7 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
%D%/packages/patches/ruby-rspec-its-remove-rspec-gemspec.patch\
%D%/packages/patches/ruby-listen-patch-gemspec.patch \
+ %D%/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
%D%/packages/patches/rust-bootstrap-stage0-test.patch \
%D%/packages/patches/rust-coresimd-doctest.patch \
diff --git a/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch b/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch
new file mode 100644
index 0000000000..e870c060a5
--- /dev/null
+++ b/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch
@@ -0,0 +1,16 @@
+diff --git a/listen.gemspec b/listen.gemspec
+index ee1316e..067dca3 100644
+--- a/listen.gemspec
++++ b/listen.gemspec
+@@ -14,9 +14,8 @@ Gem::Specification.new do |s|
+ s.description = 'The Listen gem listens to file modifications and '\
+ 'notifies you about the changes. Works everywhere!'
+
+- s.files = `git ls-files -z`.split("\x0").select do |f|
+- /^(?:bin|lib)\// =~ f
+- end + %w(CHANGELOG.md CONTRIBUTING.md LICENSE.txt README.md)
++ s.files = `find bin lib -type f |sort`.split("\n") +
++ %w(CHANGELOG.md CONTRIBUTING.md LICENSE.txt README.md)
+
+ s.test_files = []
+ s.executable = 'listen'
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b322590425..370a9a7954 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4375,6 +4375,24 @@ a native C extension.")
(home-page "https://github.com/guard/listen")
(license license:expat)))
+(define-public ruby-listen-3.0
+ (package
+ (inherit ruby-listen)
+ (name "ruby-listen")
+ (version "3.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include a Rakefile, so we fetch the tarball from
+ ;; Github.
+ (uri (string-append "https://github.com/guard/listen/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06cy038xlbi8hcr9nv0c9wvafi7s3d05sdc7ydkv8qndi9bs68l3"))
+ (patches (search-patches "ruby-listen-3.0.8-patch-gemspec.patch"))))))
+
(define-public ruby-loofah
(package
(name "ruby-loofah")