aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-05 15:37:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-05 15:39:29 +0200
commitfcd397e4a6778d16267673f08084930f07cbcb37 (patch)
tree3221969ab1b3ec89407cbb7f30695de95ed99310
parent25623a3b34f89e7c3f882b30cd679358d4c8d02b (diff)
downloadguix-fcd397e4a6778d16267673f08084930f07cbcb37.tar
guix-fcd397e4a6778d16267673f08084930f07cbcb37.tar.gz
gnu: Add python-xdg.
* gnu/packages/python-xyz.scm (python-xdg): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38af693ab6..224cfacf7a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16169,6 +16169,28 @@ interface to the Amazon Web Services (AWS) API.")
in pure Python.")
(license license:expat)))
+(define-public python-xdg
+ (package
+ (name "python-xdg")
+ (version "6.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "xdg" version))
+ (sha256
+ (base32
+ "14hwk9j5zjc8rvirw95mrb07zdnpjaxjx2mj3rnq8pnlyaa809r4"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-poetry-core))
+ (home-page "https://github.com/srstevenson/xdg-base-dirs")
+ (synopsis "Variables defined by the XDG Base Directory Specification")
+ (description "xdg-base-dirs is a Python module that provides functions to
+return paths to the directories defined by the XDG Base Directory
+Specification, to save you from duplicating the same snippet of logic in every
+Python utility you write that deals with user cache, configuration, or data
+files.")
+ (license license:isc)))
+
(define-public python-xdo
(package
(name "python-xdo")