aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-05 13:00:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-05 15:39:28 +0200
commit99627b86c8aee62e276d71889da91cb5eaaf02cb (patch)
tree6695bae60aefdf1c2c6de8021396f6f749613dc8
parent7dc853269f93093ffe94594b5e9b41fca6ddc2d5 (diff)
downloadguix-99627b86c8aee62e276d71889da91cb5eaaf02cb.tar
guix-99627b86c8aee62e276d71889da91cb5eaaf02cb.tar.gz
gnu: Add python-palettable.
* gnu/packages/python-xyz.scm (python-palettable): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa8e98b53f..137e07b0db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3374,6 +3374,26 @@ system is highly configurable via command line options and embedded
commands.")
(license license:lgpl2.1+)))
+(define-public python-palettable
+ (package
+ (name "python-palettable")
+ (version "3.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "palettable" version))
+ (sha256
+ (base32
+ "1a4h0jpsr3wjciqg9a5kslxv65d3qqgmqgkpai4cl77wlpcxfk89"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://jiffyclub.github.io/palettable/")
+ (synopsis "Color palettes for Python")
+ (description "Palettable (formerly brewer2mpl) is a library of color
+palettes for Python. It’s written in pure Python with no dependencies, but it
+can supply color maps for matplotlib. You can use Palettable to customize
+matplotlib plots or supply colors for a web application.")
+ (license license:expat)))
+
(define-public python-parse-type
(package
(name "python-parse-type")