aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-05 15:36:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-05 15:39:29 +0200
commit931650212a31e2c7c80e490e084e79754ea6c0a7 (patch)
tree5ccf5fa4cf4af0549232d70bda698da870a719e0
parent0b5088a2a3c7f78b79d3619a7be321d625514223 (diff)
downloadguix-931650212a31e2c7c80e490e084e79754ea6c0a7.tar
guix-931650212a31e2c7c80e490e084e79754ea6c0a7.tar.gz
gnu: Add python-biofluff.
* gnu/packages/bioinformatics.scm (python-biofluff): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 474b955bd0..e48b340a3a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1251,6 +1251,54 @@ Format (GFF) with Biopython integration.")
(modify-inputs (package-propagated-inputs python-bcbio-gff)
(replace "python-biopython" python-biopython-1.73)))))
+;; Note: the name on PyPi is "biofluff".
+(define-public python-biofluff
+ (package
+ (name "python-biofluff")
+ (version "3.0.4")
+ ;; PyPi tarball does not contain test data.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simonvh/fluff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12yvhgp72s2ygf3h07rrc852zd6q8swc41hm28mcczpsyprggxyz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; Theses tests require internet access
+ '(list "--ignore=tests/test_mirror.py"
+ "-k" "not test_plots_big")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'matplotlib-compatibility
+ (lambda _
+ (substitute* "fluff/plot.py"
+ (("beginarrow=False, endarrow=True,") "")))))))
+ (propagated-inputs
+ (list htseq
+ python-matplotlib
+ python-numpy
+ python-palettable
+ python-pybedtools
+ python-pybigwig
+ python-pysam
+ python-scikit-learn
+ python-scipy))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/simonvh/fluff/")
+ (synopsis "Analysis and visualization of high-throughput sequencing data")
+ (description
+ "Fluff is a Python package that contains several scripts to produce
+pretty, publication-quality figures for next-generation sequencing
+experiments.")
+ (license license:expat)))
+
(define-public python-cellbender
(package
(name "python-cellbender")