aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-05 14:25:49 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-05 14:57:29 +0100
commit6922069bcbe5c08da09c00e5aad44e390ebd1cc7 (patch)
tree775974a64a13edcedbeadab641dd1c739b3f5439
parentdc8b3ebe5d4ba2a39c12f62d836963ffee1e4b47 (diff)
downloadguix-6922069bcbe5c08da09c00e5aad44e390ebd1cc7.tar
guix-6922069bcbe5c08da09c00e5aad44e390ebd1cc7.tar.gz
gnu: gcc-11: Fix patch-hurd-libpthread phase.
It didn't work when it was introduced in 08acdd0765b5f4fbfafa699a823ea7985d4d35a7. * gnu/packages/gcc.scm (gcc-11)[arguments]: Remove the procedure arguments, and use %build-inputs rather than inputs. * gnu/packages/commencement.scm (gcc-boot0)[native-inputs]: Add hurd-patch, as this package inherits from gcc-11.
-rw-r--r--gnu/packages/commencement.scm5
-rw-r--r--gnu/packages/gcc.scm5
2 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 25e96b1aa6..fc1c508b38 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2452,7 +2452,10 @@ exec " gcc "/bin/" program
,@(alist-delete "libc" (%boot0-inputs))))
;; No need for the native-inputs to build the documentation at this stage.
- (native-inputs `())))
+ (native-inputs
+ (if (target-hurd?)
+ `(("hurd-patch" ,(search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
+ '()))))
(define perl-boot0
(package
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9ae6f77b37..fade5bb64b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -719,10 +719,9 @@ It also includes runtime support libraries for these languages.")
(if (target-hurd?)
`(modify-phases ,phases
(add-after 'unpack 'patch-hurd-libpthread
- (lambda (#:key inputs)
+ (lambda _
(invoke "patch" "--force" "-p1" "-i"
- (assoc-ref inputs "hurd-patch")
- patch))))
+ (assoc-ref %build-inputs "hurd-patch")))))
phases))))
(properties
`((compiler-cpu-architectures