aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-04 10:06:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-04 18:47:17 +0200
commit66993edc172f447b6742c03ae8fb6dbf1b5db56f (patch)
treeda22e80625fad5587d109892df17be652290fc5f
parenta5d719012e0f5115aa89b767edc1fe1a3505915c (diff)
downloadguix-66993edc172f447b6742c03ae8fb6dbf1b5db56f.tar
guix-66993edc172f447b6742c03ae8fb6dbf1b5db56f.tar.gz
gnu: Add python-iteround.
* gnu/packages/python-xyz.scm (python-iteround): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7950d4a775..e5d3897bef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31125,6 +31125,28 @@ sources. For example, it allows you to have all your casting and
parsing rules in a single place.")
(license license:bsd-3)))
+(define-public python-iteround
+ (package
+ (name "python-iteround")
+ (version "1.0.4")
+ ;; PyPI only has wheels.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cgdeboer/iteround")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1irw4sqrsgpc0ibxdv1hlx0d0jr1fqs48bj6mpfylzqkag9ywlfj"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/cgdeboer/iteround")
+ (synopsis "Sum-safe rounding for Iterables")
+ (description "Iteround is a standard library sum-safe rounding library for
+Python iterables (lists, tuples, dicts).")
+ (license license:expat)))
+
(define-public python-hypy-utils
(package
(name "python-hypy-utils")