aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-02-08 22:05:24 +0100
committerJelle Licht <jlicht@fsfe.org>2023-05-06 13:53:22 +0200
commit5133b8bfaaa43e35ac9d07af1587ee76a70ed8a3 (patch)
treecbf6991c1d2f5f49dc906dfb32f3d5c68a72dc30
parent0140e014aac7b415516378f0c2728422226ee51c (diff)
downloadguix-5133b8bfaaa43e35ac9d07af1587ee76a70ed8a3.tar
guix-5133b8bfaaa43e35ac9d07af1587ee76a70ed8a3.tar.gz
gnu: node-resolve-protobuf-schema: Ignore development dependencies.
* gnu/packages/node-xyz.scm (node-resolve-protobuf-schema)[arguments]<phases>: Explicitly patch out development dependencies. Re-enable configure phase.
-rw-r--r--gnu/packages/node-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 1b581cf3a7..cbf2665940 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -431,10 +431,9 @@ written in Javascript.")
(arguments
'(#:tests? #f
#:phases (modify-phases %standard-phases
- (replace 'configure
+ (add-after 'patch-dependencies 'delete-dependencies
(lambda _
- (invoke "npm" "--offline" "--ignore-scripts" "install"
- "--production"))))))
+ (delete-dependencies '("standard" "tape")))))))
(inputs (list node-protocol-buffers-schema))
(home-page "https://github.com/mafintosh/resolve-protobuf-schema")
(synopsis "Resolve protobuf imports")