aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-05 15:33:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-05 15:39:29 +0200
commit181714e5f81aab8968a2ec3a9bbaf65ec7ad8175 (patch)
treeee86b567d89deb2a42cf9f75b06d2acebe243831
parentf41c9409f23068b21432b21d689156d7875a86e5 (diff)
downloadguix-181714e5f81aab8968a2ec3a9bbaf65ec7ad8175.tar
guix-181714e5f81aab8968a2ec3a9bbaf65ec7ad8175.tar.gz
gnu: Add python-logomaker.
* gnu/packages/bioinformatics.scm (python-logomaker): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dcada630a0..4b2c0693d5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1447,6 +1447,29 @@ protocol. It provides a simple and reliable way to retrieve genomic data from
servers supporting the protocol.")
(license license:asl2.0)))
+(define-public python-logomaker
+ (package
+ (name "python-logomaker")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "logomaker" version))
+ (sha256
+ (base32
+ "0v9z3ml1s7imk28hqyhrqjqg3sq0j29lx975d36n2ybdgld51iyq"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-matplotlib python-numpy python-pandas))
+ (home-page "https://logomaker.readthedocs.io")
+ (synopsis "Package for making Sequence Logos")
+ (description "Logomaker is a Python package for generating
+publication-quality sequence logos. Logomaker can generate both standard and
+highly customized logos illustrating the properties of DNA, RNA, or protein
+sequences. Logos are rendered as vector graphics embedded within native
+matplotlib Axes objects, making them easy to style and incorporate into
+multi-panel figures.")
+ (license license:expat)))
+
(define-public python-pegasusio
(package
(name "python-pegasusio")