aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-04 10:51:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-04 18:47:17 +0200
commit155137d28ae988bb40b3eabf3f755bdfb7420a3d (patch)
treef125fdc40327c40f4cb711dc7acf27f3c4ebff83
parentf234cda89a974fe69354baed5f41919add91bd60 (diff)
downloadguix-155137d28ae988bb40b3eabf3f755bdfb7420a3d.tar
guix-155137d28ae988bb40b3eabf3f755bdfb7420a3d.tar.gz
gnu: Add python-loguru.
* gnu/packages/python-xyz.scm (python-loguru): New variable.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee945b658d..cf4fff9ba1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28521,6 +28521,40 @@ versions which have appeared in recent Python releases, but are usable with
older versions of Python and so are packaged here.")
(license license:bsd-3)))
+(define-public python-loguru
+ (package
+ (name "python-loguru")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "loguru" version))
+ (sha256
+ (base32
+ "1q83kr9zwwxchgyzf8gc6wi68ch5391mwzfxb5wlvs3axly0a4hn"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; All of these fail with: error: Cannot find implementation or library
+ ;; stub for module named "loguru"
+ '(list "--ignore=tests/typesafety/test_logger.yml")))
+ (propagated-inputs (list python-colorama))
+ (native-inputs (list python-colorama
+ python-freezegun
+ python-mypy
+ python-pre-commit
+ python-pytest
+ python-pytest-cov
+ python-pytest-mypy-plugins
+ python-sphinx
+ python-sphinx-autobuild
+ python-sphinx-rtd-theme
+ python-tox))
+ (home-page "https://github.com/Delgan/loguru")
+ (synopsis "Python logging made (stupidly) simple")
+ (description "Python logging made (stupidly) simple")
+ (license license:expat)))
+
(define-public python-helper
(package
(name "python-helper")