aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-12-26 17:41:27 +0000
committerVagrant Cascadian <vagrant@debian.org>2019-12-29 01:26:33 -0800
commitfa9e3b5ed2a16747d719ce49f114ce74d2e8678d (patch)
tree13442e466d9de4b77d6001485d5376441c92a084
parentbb62932ad81b58c5e06aa864245021242a8f2ff2 (diff)
downloadguix-fa9e3b5ed2a16747d719ce49f114ce74d2e8678d.tar
guix-fa9e3b5ed2a16747d719ce49f114ce74d2e8678d.tar.gz
gnu: pelican: Update to 4.2.
* gnu/packages/python-xyz (pelican): Update to 4.2. [propagated-inputs]: Alphabetize. [arguments]: Remove adjust-requires phase.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 9 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37fc53536a..f41e59c047 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3146,42 +3146,30 @@ interested parties to subscribe to events, or \"signals\".")
(define-public pelican
(package
(name "pelican")
- (version "4.0.1")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pelican" version))
(sha256
(base32
- "05yda7n6r0ll18fpdjzkzyr0ls8hbb86fnjyb33k9jvv5avah2lr"))))
+ "0mp7hjyhs38ag1hyfcy882g400z0babqi72pnli46dqijfhajzmy"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-feedgenerator" ,python-feedgenerator)
+ `(("python-blinker" ,python-blinker)
+ ("python-dateutil" ,python-dateutil)
+ ("python-docutils" ,python-docutils)
+ ("python-feedgenerator" ,python-feedgenerator)
("python-jinja2" ,python-jinja2)
+ ("python-markdown" ,python-markdown)
("python-pygments" ,python-pygments)
- ("python-docutils" ,python-docutils)
("python-pytz" ,python-pytz)
- ("python-blinker" ,python-blinker)
- ("python-unidecode" ,python-unidecode)
("python-six" ,python-six)
- ("python-dateutil" ,python-dateutil)
- ("python-markdown" ,python-markdown)))
+ ("python-unidecode" ,python-unidecode)))
(home-page "https://getpelican.com/")
(arguments
`(;; XXX Requires a lot more packages to do unit tests :P
- #:tests? #f
- #:phases (modify-phases %standard-phases
- (add-before
- 'install 'adjust-requires
- ;; Since feedgenerator is installed from git, it doesn't
- ;; conform to the version requirements.
- ;;
- ;; We *do have* "feedgenerator >= 1.6", but strip off the
- ;; version requirement so setuptools doesn't get confused.
- (lambda _
- (substitute* "setup.py"
- (("['\"]feedgenerator.*?['\"]")
- "'feedgenerator'")))))))
+ #:tests? #f))
(synopsis "Python-based static site publishing system")
(description
"Pelican is a tool to generate a static blog from reStructuredText,