aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 23:04:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-08 00:02:13 -0400
commitd2686be816183a8de1243b19f20144a2b283f7c3 (patch)
treeff6a06cf4c9566e99e3cdf1acecb66cb7d982c02
parentb1372ad8cbcb54d9c4dae698c86db06be87d242e (diff)
downloadguix-d2686be816183a8de1243b19f20144a2b283f7c3.tar
guix-d2686be816183a8de1243b19f20144a2b283f7c3.tar.gz
gnu: opendht: Update to 2.2.0rc7-1.c8a0b44.
* gnu/packages/networking.scm (opendht): Update to 2.2.0rc7-1.c8a0b44.
-rw-r--r--gnu/packages/networking.scm167
1 files changed, 85 insertions, 82 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 82c7a0161a..0769438133 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3529,87 +3529,90 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(license license:bsd-3)))
(define-public opendht
- (package
- (name "opendht")
- (version "2.2.0rc7") ;jami requires >= 2.2.0
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/savoirfairelinux/opendht")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wkynjzwzl5q46hy1yb9npi5hvknnj17rjkax5v3acqjmd0y48h9"))))
- ;; Since 2.0, the gnu-build-system does not seem to work anymore, upstream bug?
- (outputs '("out" "tools" "debug"))
- (build-system cmake-build-system)
- (inputs
- `(("argon2" ,argon2)
- ("nettle" ,nettle-3.7)
- ("readline" ,readline)
- ("jsoncpp" ,jsoncpp)
- ("openssl" ,openssl) ;required for the DHT proxy
- ("fmt" ,fmt)))
- (propagated-inputs
- `(("gnutls" ,gnutls) ;included in opendht/crypto.h
- ("msgpack" ,msgpack) ;included in several installed headers
- ("restinio" ,restinio))) ;included in opendht/http.h
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("python-cython" ,python-cython)
- ("libtool" ,libtool)
- ("cppunit" ,cppunit)))
- (arguments
- `(#:imported-modules ((guix build python-build-system) ;for site-packages
- ,@%cmake-build-system-modules)
- #:modules (((guix build python-build-system) #:prefix python:)
- (guix build cmake-build-system)
- (guix build utils))
- #:tests? #f ; Tests require network connection.
- #:configure-flags
- '( ;;"-DOPENDHT_TESTS=on"
- "-DOPENDHT_STATIC=off"
- "-DOPENDHT_TOOLS=on"
- "-DOPENDHT_PYTHON=on"
- "-DOPENDHT_PROXY_SERVER=on"
- "-DOPENDHT_PUSH_NOTIFICATIONS=on"
- "-DOPENDHT_PROXY_SERVER_IDENTITY=on"
- "-DOPENDHT_PROXY_CLIENT=on")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-python-installation-prefix
- ;; Specify the installation prefix for the compiled Python module
- ;; that would otherwise attempt to installs itself to Python's own
- ;; site-packages directory.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "python/CMakeLists.txt"
- (("--root=\\\\\\$ENV\\{DESTDIR\\}")
- (string-append "--root=/ --single-version-externally-managed "
- "--prefix=${CMAKE_INSTALL_PREFIX}")))))
- (add-after 'unpack 'specify-runpath-for-python-module
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "python/setup.py.in"
- (("extra_link_args=\\[(.*)\\]" _ args)
- (string-append "extra_link_args=[" args
- ", '-Wl,-rpath=" out "/lib']"))))))
- (add-after 'install 'move-and-wrap-tools
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (tools (assoc-ref outputs "tools"))
- (site-packages (python:site-packages inputs outputs)))
- (mkdir tools)
- (rename-file (string-append out "/bin")
- (string-append tools "/bin"))
- (wrap-program (string-append tools "/bin/dhtcluster")
- `("PYTHONPATH" prefix (,site-packages)))))))))
- (home-page "https://github.com/savoirfairelinux/opendht/")
- (synopsis "Lightweight Distributed Hash Table (DHT) library")
- (description "OpenDHT provides an easy to use distributed in-memory data
+ ;; Jami requires unreleased features of OpenDHT.
+ (let ((commit "c8a0b443f3117e2fa1343d2cb3c091f502b1a24e")
+ (revision "1"))
+ (package
+ (name "opendht")
+ (version (git-version "2.2.0rc7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/savoirfairelinux/opendht")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "062irb9yii66n2fzbpsjf7v2v53zzvakr1wjmi4l1jaz33fwx5by"))))
+ ;; Since 2.0, the gnu-build-system does not seem to work anymore, upstream bug?
+ (outputs '("out" "tools" "debug"))
+ (build-system cmake-build-system)
+ (inputs
+ `(("argon2" ,argon2)
+ ("nettle" ,nettle-3.7)
+ ("readline" ,readline)
+ ("jsoncpp" ,jsoncpp)
+ ("openssl" ,openssl) ;required for the DHT proxy
+ ("fmt" ,fmt)))
+ (propagated-inputs
+ `(("gnutls" ,gnutls) ;included in opendht/crypto.h
+ ("msgpack" ,msgpack) ;included in several installed headers
+ ("restinio" ,restinio))) ;included in opendht/http.h
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("python-cython" ,python-cython)
+ ("libtool" ,libtool)
+ ("cppunit" ,cppunit)))
+ (arguments
+ `(#:imported-modules ((guix build python-build-system) ;for site-packages
+ ,@%cmake-build-system-modules)
+ #:modules (((guix build python-build-system) #:prefix python:)
+ (guix build cmake-build-system)
+ (guix build utils))
+ #:tests? #f ; Tests require network connection.
+ #:configure-flags
+ '( ;;"-DOPENDHT_TESTS=on"
+ "-DOPENDHT_STATIC=off"
+ "-DOPENDHT_TOOLS=on"
+ "-DOPENDHT_PYTHON=on"
+ "-DOPENDHT_PROXY_SERVER=on"
+ "-DOPENDHT_PUSH_NOTIFICATIONS=on"
+ "-DOPENDHT_PROXY_SERVER_IDENTITY=on"
+ "-DOPENDHT_PROXY_CLIENT=on")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-python-installation-prefix
+ ;; Specify the installation prefix for the compiled Python module
+ ;; that would otherwise attempt to installs itself to Python's own
+ ;; site-packages directory.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "python/CMakeLists.txt"
+ (("--root=\\\\\\$ENV\\{DESTDIR\\}")
+ (string-append "--root=/ --single-version-externally-managed "
+ "--prefix=${CMAKE_INSTALL_PREFIX}")))))
+ (add-after 'unpack 'specify-runpath-for-python-module
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "python/setup.py.in"
+ (("extra_link_args=\\[(.*)\\]" _ args)
+ (string-append "extra_link_args=[" args
+ ", '-Wl,-rpath=" out "/lib']"))))))
+ (add-after 'install 'move-and-wrap-tools
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (tools (assoc-ref outputs "tools"))
+ (site-packages (python:site-packages inputs outputs)))
+ (mkdir tools)
+ (rename-file (string-append out "/bin")
+ (string-append tools "/bin"))
+ (wrap-program (string-append tools "/bin/dhtcluster")
+ `("PYTHONPATH" prefix (,site-packages)))))))))
+ (home-page "https://github.com/savoirfairelinux/opendht/")
+ (synopsis "Lightweight Distributed Hash Table (DHT) library")
+ (description "OpenDHT provides an easy to use distributed in-memory data
store. Every node in the network can read and write values to the store.
Values are distributed over the network, with redundancy. It includes the
following features:
@@ -3632,7 +3635,7 @@ library (get, put, etc.) with text values.
@item dhtchat
A very simple IM client working over the DHT.
@end table")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public frrouting
(package