aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-06-07 19:16:47 -0400
committerLeo Famulari <leo@famulari.name>2021-06-07 19:23:39 -0400
commitb1372ad8cbcb54d9c4dae698c86db06be87d242e (patch)
tree22b7e4c7f87767d8e4b54f8f6c388469b6975ed7
parent4a01e00a13323d232d66e9b4784cff91b5d992d1 (diff)
downloadguix-b1372ad8cbcb54d9c4dae698c86db06be87d242e.tar
guix-b1372ad8cbcb54d9c4dae698c86db06be87d242e.tar.gz
gnu: Add l3afpad.
* gnu/packages/text-editors.scm (l3afpad): New variable.
-rw-r--r--gnu/packages/text-editors.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 012059dca5..0b6a4cd1f5 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2020 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
+;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -396,6 +397,38 @@ features are implemented in the editor. Leafpad is simple to use, is easily
compiled, requires few libraries, and starts up quickly. ")
(license license:gpl2+)))
+(define-public l3afpad
+ (let ((commit "5235c9e13bbf0d31a902c6776918c2d7cdbb61ff")
+ (revision "0"))
+ (package
+ (name "l3afpad")
+ (version (git-version "0.8.18.1.11" revision commit))
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/stevenhoneyman/l3afpad")
+ (commit commit)))
+ (sha256
+ (base32
+ "1alyghm2wpakzdfag0g4g8gb1h9l4wdg7mnhq8bk0iq5ryqia16a"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (home-page "http://tarot.freeshell.org/leafpad/")
+ (synopsis "GTK+ 3 based text editor")
+ (description "L3afpad is a GTK+ 3 text editor that emphasizes simplicity. As
+ development focuses on keeping weight down to a minimum, only the most essential
+ features are implemented in the editor. L3afpad is simple to use, is easily
+ compiled, requires few libraries, and starts up quickly. L3afpad is a
+ fork of Leafpad that uses GTK+ 3 instead of GTK+ 2.")
+ (license license:gpl2+))))
+
(define-public e3
(package
(name "e3")