aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-07 11:35:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-07 16:50:33 +0200
commit176513f5f3d09f9604a601fab7ba193e95a29c35 (patch)
tree6e9a662eb912ba6c6780ac2394a6acf94d9e7016
parente3611cc412e7b1c750a56d17fb1b7cde684baa3f (diff)
downloadguix-176513f5f3d09f9604a601fab7ba193e95a29c35.tar
guix-176513f5f3d09f9604a601fab7ba193e95a29c35.tar.gz
gnu: jellyfish: Update to 2.3.0.
* gnu/packages/bioinformatics.scm (jellyfish): Update to 2.3.0. [arguments]: Disable SSE to avoid tuning to the build node's CPU. [native-inputs]: Replace python-2 with python-wrapper. [license]: Update.
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 788e7ae836..365a30c166 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4715,7 +4715,7 @@ experiments and provide highly stable thresholds based on reproducibility.")
(define-public jellyfish
(package
(name "jellyfish")
- (version "2.2.10")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/gmarcais/Jellyfish/"
@@ -4723,14 +4723,15 @@ experiments and provide highly stable thresholds based on reproducibility.")
"/jellyfish-" version ".tar.gz"))
(sha256
(base32
- "1k4pc3fvv6w1km2yph4m5sd78fbxp21d6xyzgmy0gjihzc6mb249"))))
+ "0npa62wzasdibas5zp3n8j3armsci4kyvh0jw7jr0am4gg7vg5g1"))))
(build-system gnu-build-system)
(outputs '("out" ;for library
"ruby" ;for Ruby bindings
"python")) ;for Python bindings
(arguments
`(#:configure-flags
- (list (string-append "--enable-ruby-binding="
+ (list "--without-sse" ; configure script probes for CPU features when SSE is enabled.
+ (string-append "--enable-ruby-binding="
(assoc-ref %outputs "ruby"))
(string-append "--enable-python-binding="
(assoc-ref %outputs "python")))
@@ -4740,13 +4741,12 @@ experiments and provide highly stable thresholds based on reproducibility.")
(lambda _
;; generator_manager.hpp either uses /bin/sh or $SHELL
;; to run tests.
- (setenv "SHELL" (which "bash"))
- #t)))))
+ (setenv "SHELL" (which "bash")))))))
(native-inputs
`(("bc" ,bc)
("time" ,time)
("ruby" ,ruby)
- ("python" ,python-2)
+ ("python" ,python-wrapper)
("pkg-config" ,pkg-config)))
(inputs
`(("htslib" ,htslib)))
@@ -4762,9 +4762,8 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
(home-page "http://www.genome.umd.edu/jellyfish.html")
;; JELLYFISH seems to be 64-bit only.
(supported-systems '("x86_64-linux" "aarch64-linux" "mips64el-linux"))
- ;; The combined work is published under the GPLv3 or later. Individual
- ;; files such as lib/jsoncpp.cpp are released under the Expat license.
- (license (list license:gpl3+ license:expat))))
+ ;; One of these licenses may be picked
+ (license (list license:gpl3+ license:bsd-3))))
(define-public khmer
(package