aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-04 21:59:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:06 -0400
commitd4f65bc4ba0890f32155f0cb1711df6c09772ccd (patch)
tree4441a5c590e5c269b306135073f2528ed73b079b
parent9dd03cdbba55779d7904ba555635286b0a7c1640 (diff)
downloadguix-d4f65bc4ba0890f32155f0cb1711df6c09772ccd.tar
guix-d4f65bc4ba0890f32155f0cb1711df6c09772ccd.tar.gz
gnu: Add python-pytest-param-files.
* gnu/packages/check.scm (python-pytest-param-files): New variable.
-rw-r--r--gnu/packages/check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index add30452d9..ec2545dbbf 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -90,6 +90,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1))
@@ -1246,6 +1247,25 @@ supports coverage of subprocesses.")
contacting the real http server.")
(license license:expat)))
+(define-public python-pytest-param-files
+ (package
+ (name "python-pytest-param-files")
+ (version "0.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_param_files" version))
+ (sha256
+ (base32
+ "0gc9nsqizrjapjnbcs1bdxfcl69dpmwbpd9sssjidgcikm7k433c"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (propagated-inputs (list python-pytest))
+ (home-page "https://github.com/chrisjsewell/pytest-param-files")
+ (synopsis "Pytest plugin to parameterize tests from external files")
+ (description "This Pytest plugin enables creating Pytest parametrize
+decorators from external files.")
+ (license license:expat)))
+
(define-public python-pytest-random-order
(package
(name "python-pytest-random-order")