aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-04 21:47:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:05 -0400
commit9dd03cdbba55779d7904ba555635286b0a7c1640 (patch)
treec11ecc623d8d6067c4d04912d662779f39b5f73e
parent2b1cf6906d521d74802577f5c691bba0bb9b4088 (diff)
downloadguix-9dd03cdbba55779d7904ba555635286b0a7c1640.tar
guix-9dd03cdbba55779d7904ba555635286b0a7c1640.tar.gz
gnu: Add python-sphinx-pytest.
* gnu/packages/sphinx.scm (python-sphinx-pytest): New variable.
-rw-r--r--gnu/packages/sphinx.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 8dad118f34..5b3e885647 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -42,6 +42,7 @@
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages check)
@@ -898,6 +899,26 @@ enabled web server.")
documenting acceptable argument types and return value types of functions.")
(license license:expat)))
+(define-public python-sphinx-pytest
+ (package
+ (name "python-sphinx-pytest")
+ (version "0.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx_pytest" version))
+ (sha256
+ (base32
+ "13d3psm5vyb8rdj0mhnpn5m09k8xdaszcxdpng52fpz9sw8pngk7"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (propagated-inputs (list python-pytest python-sphinx))
+ (home-page "https://github.com/chrisjsewell/sphinx-pytest")
+ (synopsis "Pytest fixtures for Sphinx extensions")
+ (description "This Pytest extension mainly provides some Pytest fixtures
+to simulate converting some source text to Docutils @acronym{AST, Abstract
+Syntax Tree} at different stages: before transforms, after transforms, etc.")
+ (license license:expat)))
+
(define-public python-nbsphinx
(package
(name "python-nbsphinx")