aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-15 00:52:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-11-04 13:39:12 +0100
commit14cbaac69c142b9e45c4ff111668bf187994bab8 (patch)
treecb6fe8b5ca4faa4279917752ebb773e045736b29
parent12b83f697def2679a8f8bc0d6b11690bcce48e25 (diff)
downloadguix-14cbaac69c142b9e45c4ff111668bf187994bab8.tar
guix-14cbaac69c142b9e45c4ff111668bf187994bab8.tar.gz
gnu: Add python-bioframe.
X-Debbugs-Cc: rekado@elephly.net * gnu/packages/bioinformatics.scm (python-bioframe): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8dd260f509..53daf4c2a7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -946,6 +946,51 @@ Python.")
;; licensed lgpl2.1+
(license (list license:expat license:lgpl2.1+))))
+(define-public python-bioframe
+ (package
+ (name "python-bioframe")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ ;; pypi version does not contain tests and requirements.txt
+ (uri (git-reference
+ (url "https://github.com/open2c/bioframe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14lvb18d4npapyi6j2zqh9q94l658dzmka5riiizw1h0zb0kp9xb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (setenv "MPLCONFIGDIR" "/tmp")
+ (when tests?
+ (invoke "pytest" "-v")))))))
+ (native-inputs
+ (list python-biopython
+ python-pysam
+ python-pytest
+ python-wheel))
+ (propagated-inputs
+ (list python-matplotlib
+ python-numpy
+ python-pandas
+ python-requests))
+ (home-page "https://github.com/open2c/bioframe")
+ (synopsis "Pandas utilities for tab-delimited and other genomic files")
+ (description
+ "This package is a library to enable flexible and scalable operations on
+genomic interval dataframes in Python. Bioframe enables access to a rich set
+of dataframe operations. Working in Python enables rapid visualization and
+iteration of genomic analyses. The philosophy underlying bioframe is to
+enable flexible operations. Instead of creating a function for every possible
+use-case, we encourage users to compose functions to achieve their goals.")
+ (license license:expat)))
+
(define-public python-biom-format
(package
(name "python-biom-format")