aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-11 15:18:25 +0200
committerLeo Famulari <leo@famulari.name>2018-10-02 15:46:03 -0400
commitf6890c08912c7b2a2b7f6c1cdeda412ff73e0b1d (patch)
tree6cf3249351155530685fd2328239413e8f589115
parent7d15490cd247c35aeac170e2cf002d1fd93b775a (diff)
downloadguix-f6890c08912c7b2a2b7f6c1cdeda412ff73e0b1d.tar
guix-f6890c08912c7b2a2b7f6c1cdeda412ff73e0b1d.tar.gz
gnu: Add r-rbenchmark.
gnu/packages/cran.scm (r-rbenchmark): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 186a52a1f1..76c9c734f2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6057,3 +6057,28 @@ on user-defined cut-points of accelerometer counts.
and generates data summaries. Also, includes functions to plot, analyze, and
simulate accelerometer data.")
(license license:gpl2+)))
+
+(define-public r-rbenchmark
+ (package
+ (name "r-rbenchmark")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rbenchmark" version))
+ (sha256
+ (base32 "010fn3qwnk2k411cbqyvra1d12c3bhhl3spzm8kxffmirj4p2al9"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/rbenchmark/")
+ (synopsis "Benchmarking routine for R")
+ (description
+ "This @code{r-rbenchmark} package is inspired by the Perl module Benchmark,
+and is intended to facilitate benchmarking of arbitrary R code. The library
+consists of just one function, benchmark, which is a simple wrapper around
+system.time. Given a specification of the benchmarking process (counts of
+replications, evaluation environment) and an arbitrary number of expressions,
+benchmark evaluates each of the expressions in the specified environment,
+replicating the evaluation as many times as specified, and returning the results
+conveniently wrapped into a data frame.")
+ (license license:gpl2+)))
+