aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-10-03 21:32:49 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-03 21:54:56 +0800
commitd1022d68c25ab95ba789e02164326af47fd18a80 (patch)
treeee32d278883d25edde1fe0a6b3ab11292866d4f5
parentd7d1fc821091de98d66dac71ceed390d82434e40 (diff)
downloadguix-d1022d68c25ab95ba789e02164326af47fd18a80.tar
guix-d1022d68c25ab95ba789e02164326af47fd18a80.tar.gz
gnu: guile-chickadee: Update to 0.3.0.
* gnu/packages/game-development.scm (guile-chickadee): Update to 0.3.0. [arguments]: Add 'patch-godir' phase.
-rw-r--r--gnu/packages/game-development.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 86f2877f82..6bd72879c2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1256,17 +1256,24 @@ a 2D editor view.")
(define-public guile-chickadee
(package
(name "guile-chickadee")
- (version "0.2.0")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/chickadee/"
"chickadee-" version ".tar.gz"))
(sha256
(base32
- "10qx0ha5gsayybd186r1my7vc7rf5fbzp9jvmc4xg9a8wz8rqhah"))))
+ "0jl223dybsj5gvs7z4q60gnafj1b7kgi5mx0kj58m5knrp8qwg5h"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("GUILE_AUTO_COMPILE=0")))
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-godir
+ (lambda _
+ ;; Install compiled '.go' files into the site directory.
+ (substitute* "Makefile.in"
+ (("/ccache") "/site-ccache")))))))
(propagated-inputs
`(("guile-opengl" ,guile-opengl)
("guile-sdl2" ,guile-sdl2)))