aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-24 18:03:06 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-24 18:06:33 +0100
commit8f3e10ae819aabbe8216bfee6cd3e7857bc27293 (patch)
treee58beb120d6a616d365c6461dc2d2cc65bf95d66
parentb438e1f2311a06c309f7b4cf29683463bf446da1 (diff)
downloadguix-8f3e10ae819aabbe8216bfee6cd3e7857bc27293.tar
guix-8f3e10ae819aabbe8216bfee6cd3e7857bc27293.tar.gz
gnu: emacs-projectile: Activate tests.
* gnu/packages/emacs-xyz.scm (emacs-projectile)[source]: Use Git repository instead of released tarball to get the test file. [arguments]: Activate tests, and fix a failing one.
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0132193197..2eef75925a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11836,15 +11836,29 @@ like @code{org-edit-src-code} but for arbitrary regions.")
(package
(name "emacs-projectile")
(version "2.7.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com/bbatsov"
- "/projectile/v" version "/projectile.el"))
- (file-name (string-append "projectile-" version ".el"))
- (sha256
- (base32
- "1jd1csrvafy49dcfag0ccpqbdn5my183h325bv6j4x4c3a6qbp98"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bbatsov/projectile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ybd41iss8vd56qv6czpxqq7a99s4h7i3a2r4khy4rf5blj5zdqi"))))
(build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "buttercup" "-L" ".")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-failing-test
+ (lambda _
+ (substitute* "test/projectile-test.el"
+ (("user-emacs-directory") "\".\"")))))))
+ (native-inputs
+ (list emacs-buttercup))
(propagated-inputs
(list emacs-dash emacs-pkg-info))
(home-page "https://github.com/bbatsov/projectile")