aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-24 17:01:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-24 18:02:15 +0100
commit697a0f8ca486842e73cd81ac3157b0ab5ad70fc5 (patch)
tree00299decad419e992b95859bf326a8532fb3610f
parent8b1bee45f7fe37fd46e449910ff4ceb421e8ad87 (diff)
downloadguix-697a0f8ca486842e73cd81ac3157b0ab5ad70fc5.tar
guix-697a0f8ca486842e73cd81ac3157b0ab5ad70fc5.tar.gz
gnu: Add r-scs.
* gnu/packages/cran.scm (r-scs): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 88600988c4..daa1249892 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21017,6 +21017,30 @@ errors and possible semantic issues. It supports on the fly checking of R
code edited with @code{RStudio IDE}, @code{Emacs} and @code{Vim}.")
(license license:expat)))
+(define-public r-scs
+ (package
+ (name "r-scs")
+ (version "3.0-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "scs" version))
+ (sha256
+ (base32
+ "04srf33zw4dxv22b1h5qwjch5yg7hrvk4iq8yvxqnbr8qzp1x26n"))))
+ (properties `((upstream-name . "scs")))
+ (build-system r-build-system)
+ (home-page "https://github.com/FlorianSchwendinger/scs")
+ (synopsis "Splitting conic solver")
+ (description
+ "This package solves convex cone programs via operator splitting.
+It can solve: linear programs, second-order cone programs,
+semidefinite programs, exponential cone programs, and power cone
+programs, or problems with any combination of those cones. SCS uses
+AMD (a set of routines for permuting sparse matrices prior to
+factorization) and LDL (a sparse LDL factorization and solve package)
+from SuiteSparse.")
+ (license license:gpl3)))
+
(define-public r-sctransform
(package
(name "r-sctransform")