aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-25 07:12:23 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-25 10:23:39 +0100
commit5c93d5136622df41ca799d122a4d1d6cfd6b28d5 (patch)
tree3c31fd5713465360e2c544f1140f985c79e4be78
parentfe09d32e34d30c92587536b581361e8c9be850f2 (diff)
downloadguix-5c93d5136622df41ca799d122a4d1d6cfd6b28d5.tar
guix-5c93d5136622df41ca799d122a4d1d6cfd6b28d5.tar.gz
gnu: Add cl-marray.
* gnu/packages/lisp-xyz.scm (sbcl-marray, cl-marray): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 190061b855..aee311c2dd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13061,6 +13061,44 @@ than a few Kb.")
(define-public ecl-mmap
(sbcl-package->ecl-package sbcl-mmap))
+(define-public sbcl-marray
+ (let ((commit "0352f316b6830f0b119088ba9be836e4726bd7d8")
+ (revision "0"))
+ (package
+ (name "sbcl-marray")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/death/marray")
+ (commit commit)))
+ (file-name (git-file-name "cl-marray" version))
+ (sha256
+ (base32 "0l4kvzpiw14vqhlsaflp3c7y51vznjjgbdi0q3axqk1wxvzy1zlx"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dependencies
+ (lambda _
+ (substitute* "marray.asd"
+ ((":components")
+ ":depends-on (#+sbcl \"sb-posix\")\n :components")))))))
+ (home-page "https://github.com/death/marray")
+ (synopsis "Memory-mapped files as Common Lisp arrays")
+ (description
+ "MARRAY is a library which provides access to memory-mapped files
+through Common Lisp arrays.")
+ (license license:expat))))
+
+(define-public cl-marray
+ (sbcl-package->cl-source-package sbcl-marray))
+
+;; ECL support not implemented yet.
+;; (define-public ecl-marray
+;; (sbcl-package->ecl-package sbcl-marray))
+
(define-public sbcl-3bz
(let ((commit "569614c40408f3aefc77ba233e0e4bd66d3850ad")
(revision "1"))