aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-25 07:29:56 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-25 10:25:49 +0100
commit13eafd67301b37b6490d666c4f78d6c26337c052 (patch)
tree895ddf208e61d2c7893327c9a3457d6c461b9444
parent5c93d5136622df41ca799d122a4d1d6cfd6b28d5 (diff)
downloadguix-13eafd67301b37b6490d666c4f78d6c26337c052.tar
guix-13eafd67301b37b6490d666c4f78d6c26337c052.tar.gz
gnu: Add cl-file-notify.
* gnu/packages/lisp-xyz.scm (sbcl-file-notify, cl-file-notify, ecl-file-notify): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index aee311c2dd..56178a82cd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -490,6 +490,39 @@ interface to the Linux inotify API.")
(define-public ecl-cl-inotify
(sbcl-package->ecl-package sbcl-cl-inotify))
+(define-public sbcl-file-notify
+ (let ((commit "f12dc2f2aae5fee13355cd93a8cae0c4c412b76d")
+ (revision "0"))
+ (package
+ (name "sbcl-file-notify")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/file-notify")
+ (commit commit)))
+ (file-name (git-file-name "cl-file-notify" version))
+ (sha256
+ (base32 "0788d98rqm1krl8nbfh8qshvyf6g336i9bqrdhkx06cfvbh0wcny"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-cffi
+ sbcl-documentation-utils
+ sbcl-trivial-features))
+ (home-page "https://github.com/Shinmera/file-notify")
+ (synopsis "Get notifications for file accesses and changes")
+ (description
+ "File-Notify is a Common Lisp library for getting notifications for file
+accesses and changes.")
+ (license license:zlib))))
+
+(define-public cl-file-notify
+ (sbcl-package->cl-source-package sbcl-file-notify))
+
+(define-public ecl-file-notify
+ (sbcl-package->ecl-package sbcl-file-notify))
+
(define-public sbcl-bodge-queue
(let ((commit "948c9a501dcd412689952d09eb7453ec2722336a")
(revision "0"))