aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-29 05:54:54 -0500
committerMark H Weaver <mhw@netris.org>2018-01-30 03:51:11 -0500
commite0e10e2f58a84054a2092b217501272433b8c43c (patch)
treefe8396c5ee7928ab7e792e9b0df7559db919f171
parent33c88fcb2588e5b74f8f2f7a78227950e5199a3c (diff)
downloadguix-e0e10e2f58a84054a2092b217501272433b8c43c.tar
guix-e0e10e2f58a84054a2092b217501272433b8c43c.tar.gz
gnu: linux-libre: NVME core support is now built-in.
* gnu/system/linux-initrd.scm (base-initrd)[linux-modules]: Remove "nvme". * gnu/packages/aux-files/linux-libre/4.1-i686.conf, gnu/packages/aux-files/linux-libre/4.1-x86_64.conf, gnu/packages/aux-files/linux-libre/4.4-i686.conf, gnu/packages/aux-files/linux-libre/4.4-x86_64.conf: Set CONFIG_BLK_DEV_NVME=y. * gnu/packages/aux-files/linux-libre/4.9-i686.conf, gnu/packages/aux-files/linux-libre/4.9-x86_64.conf, gnu/packages/aux-files/linux-libre/4.14-arm.conf, gnu/packages/aux-files/linux-libre/4.14-i686.conf, gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: Set CONFIG_BLK_DEV_NVME=y and CONFIG_NVME_CORE=y.
-rw-r--r--gnu/packages/aux-files/linux-libre/4.1-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.1-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.14-arm.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/4.14-i686.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/4.14-x86_64.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/4.4-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.4-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.9-i686.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/4.9-x86_64.conf4
-rw-r--r--gnu/system/linux-initrd.scm1
10 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/aux-files/linux-libre/4.1-i686.conf b/gnu/packages/aux-files/linux-libre/4.1-i686.conf
index a37225541e..24b5e61152 100644
--- a/gnu/packages/aux-files/linux-libre/4.1-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.1-i686.conf
@@ -1954,7 +1954,7 @@ CONFIG_BLK_DEV_CRYPTOLOOP=m
CONFIG_BLK_DEV_DRBD=m
# CONFIG_DRBD_FAULT_INJECTION is not set
CONFIG_BLK_DEV_NBD=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_BLK_DEV_NVME=y
CONFIG_BLK_DEV_OSD=m
CONFIG_BLK_DEV_SX8=m
CONFIG_BLK_DEV_RAM=y
diff --git a/gnu/packages/aux-files/linux-libre/4.1-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.1-x86_64.conf
index 82c5824923..c89bfedd41 100644
--- a/gnu/packages/aux-files/linux-libre/4.1-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.1-x86_64.conf
@@ -1919,7 +1919,7 @@ CONFIG_BLK_DEV_CRYPTOLOOP=m
CONFIG_BLK_DEV_DRBD=m
# CONFIG_DRBD_FAULT_INJECTION is not set
CONFIG_BLK_DEV_NBD=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_BLK_DEV_NVME=y
CONFIG_BLK_DEV_SKD=m
CONFIG_BLK_DEV_OSD=m
CONFIG_BLK_DEV_SX8=m
diff --git a/gnu/packages/aux-files/linux-libre/4.14-arm.conf b/gnu/packages/aux-files/linux-libre/4.14-arm.conf
index 2bde47018a..bc7fe85aec 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-arm.conf
@@ -2051,8 +2051,8 @@ CONFIG_VIRTIO_BLK=m
# CONFIG_VIRTIO_BLK_SCSI is not set
CONFIG_BLK_DEV_RBD=m
# CONFIG_BLK_DEV_RSXX is not set
-CONFIG_NVME_CORE=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_NVME_CORE=y
+CONFIG_BLK_DEV_NVME=y
CONFIG_NVME_FABRICS=m
CONFIG_NVME_RDMA=m
# CONFIG_NVME_FC is not set
diff --git a/gnu/packages/aux-files/linux-libre/4.14-i686.conf b/gnu/packages/aux-files/linux-libre/4.14-i686.conf
index c7b65d2125..eb471a324d 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-i686.conf
@@ -2156,8 +2156,8 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_VIRTIO_BLK_SCSI is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_NVME_CORE=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_NVME_CORE=y
+CONFIG_BLK_DEV_NVME=y
CONFIG_NVME_FABRICS=m
CONFIG_NVME_RDMA=m
CONFIG_NVME_FC=m
diff --git a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
index 6fe42fd505..1f2be0a0a1 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
@@ -2140,8 +2140,8 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_VIRTIO_BLK_SCSI is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_NVME_CORE=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_NVME_CORE=y
+CONFIG_BLK_DEV_NVME=y
CONFIG_NVME_FABRICS=m
CONFIG_NVME_RDMA=m
CONFIG_NVME_FC=m
diff --git a/gnu/packages/aux-files/linux-libre/4.4-i686.conf b/gnu/packages/aux-files/linux-libre/4.4-i686.conf
index e877f195af..0ce2473f35 100644
--- a/gnu/packages/aux-files/linux-libre/4.4-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.4-i686.conf
@@ -2016,7 +2016,7 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_BLK_DEV_NVME=y
#
# Misc devices
diff --git a/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
index 406053ab7a..5024685b61 100644
--- a/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
@@ -1980,7 +1980,7 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_BLK_DEV_NVME=y
#
# Misc devices
diff --git a/gnu/packages/aux-files/linux-libre/4.9-i686.conf b/gnu/packages/aux-files/linux-libre/4.9-i686.conf
index 4f3a9f9271..9120450740 100644
--- a/gnu/packages/aux-files/linux-libre/4.9-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.9-i686.conf
@@ -2105,8 +2105,8 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_NVME_CORE=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_NVME_CORE=y
+CONFIG_BLK_DEV_NVME=y
# CONFIG_BLK_DEV_NVME_SCSI is not set
CONFIG_NVME_FABRICS=m
CONFIG_NVME_RDMA=m
diff --git a/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
index ca0fcded61..35e38c93a2 100644
--- a/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
@@ -2081,8 +2081,8 @@ CONFIG_VIRTIO_BLK=y
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_RBD=m
CONFIG_BLK_DEV_RSXX=m
-CONFIG_NVME_CORE=m
-CONFIG_BLK_DEV_NVME=m
+CONFIG_NVME_CORE=y
+CONFIG_BLK_DEV_NVME=y
# CONFIG_BLK_DEV_NVME_SCSI is not set
CONFIG_NVME_FABRICS=m
CONFIG_NVME_RDMA=m
diff --git a/gnu/system/linux-initrd.scm b/gnu/system/linux-initrd.scm
index 0f7f4721dd..330438bce4 100644
--- a/gnu/system/linux-initrd.scm
+++ b/gnu/system/linux-initrd.scm
@@ -290,7 +290,6 @@ loaded at boot time in the order in which they appear."
"usb-storage" "uas" ;for the installation image etc.
"usbhid" "hid-generic" "hid-apple" ;keyboards during early boot
"dm-crypt" "xts" "serpent_generic" "wp512" ;for encrypted root partitions
- "nvme" ;for new SSD NVMe devices
"nls_iso8859-1" ;for `mkfs.fat`, et.al
,@(if (string-match "^(x86_64|i[3-6]86)-" (%current-system))
'("pata_acpi" "pata_atiixp" ;for ATA controllers