aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:56:01 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:02 +0000
commit4e2c79abaedd862ab817cb2811713ca941a622a1 (patch)
tree90651c4d038ac054e2c4cd879b7041c98c0d0903
parent155465478b3b092480bec500d19f1cd712ab8ce5 (diff)
downloadguix-4e2c79abaedd862ab817cb2811713ca941a622a1.tar
guix-4e2c79abaedd862ab817cb2811713ca941a622a1.tar.gz
gnu: Add ruby-rr.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a4395ba197..aa867c74a0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6863,3 +6863,27 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/flavorjones/loofah")
(license license:expat)))
+
+(define-public ruby-rr
+(package
+ (name "ruby-rr")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rr" version))
+ (sha256
+ (base32
+ "0b05ycaw17wbxzycv1wvzklpqjnmi0dqy01igcl5jfmy1ydky66r"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test files not included
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (description
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (home-page "https://rr.github.io/rr")
+ (license license:expat)))