aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:50:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:01 +0000
commit136f916b0353b69159113e328ff90405cc22d3ca (patch)
treeefa979fee40c8cf22eefcfaaa36805f29b91d117
parente2d2ac09293f5d0073ce454ada5e9b180aaf6e83 (diff)
downloadguix-136f916b0353b69159113e328ff90405cc22d3ca.tar
guix-136f916b0353b69159113e328ff90405cc22d3ca.tar.gz
gnu: Add ruby-highline.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0e13202484..99e795661d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6577,3 +6577,30 @@ but it can function as a stand-alone templating engine.")
"multi-layer client for the github api v3")
(home-page "http://gh.rkh.im/")
(license license:expat)))
+
+(define-public ruby-highline
+ (package
+ (name "ruby-highline")
+ (version "1.7.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "highline" version))
+ (sha256
+ (base32
+ "1nf5lgdn6ni2lpfdn4gk3gi47fmnca2bdirabbjbz1fk9w4p8lkr"))))
+ (build-system ruby-build-system)
+ (synopsis
+ "A high-level IO library that provides validation, type conversion, and more for
+command-line interfaces. HighLine also includes a complete menu system that can
+crank out anything from simple list selection to complete shells with just
+minutes of work.
+")
+ (description
+ "A high-level IO library that provides validation, type conversion, and more for
+command-line interfaces. HighLine also includes a complete menu system that can
+crank out anything from simple list selection to complete shells with just
+minutes of work.
+")
+ (home-page "https://github.com/JEG2/highline")
+ (license #f)))