aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-23 05:51:01 +0200
committerChristopher Baines <mail@cbaines.net>2022-11-05 11:28:42 +0100
commitb3147b149c8c44f5b4fe20936438165fa449fe20 (patch)
tree33aca2e88b534ffc6c9fffd74930cf825c85046f
parent02a53634806386cd6f0e0de3b2decb451c52225b (diff)
downloadguix-b3147b149c8c44f5b4fe20936438165fa449fe20.tar
guix-b3147b149c8c44f5b4fe20936438165fa449fe20.tar.gz
gnu: python-canonicaljson: Update to 1.6.3.
* gnu/packages/python-xyz.scm (python-canonicaljson): Update to 1.6.3. [arguments]: Add phases build, check and install to build with pep517. Add phase loosen-requirements to build with python-setuptools-scm >3. [native-inputs]: Add python-pypa-build, python-pytest, python-setuptools, python-setuptools-scm. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd713c565e..b2e64677cf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26157,14 +26157,39 @@ information for your operating system.")
(define-public python-canonicaljson
(package
(name "python-canonicaljson")
- (version "1.4.0")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "canonicaljson" version))
(sha256
- (base32 "0c86g0vvzdcg3nrcsqnbzlfhpprc2i894p8i14hska56yl27d6w9"))))
+ (base32 "0j5lq191jkd483q6xzc16c9fahxf15lrv03mvah9ka3lq85pcnfa"))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ ;; Permit newer versions of setuptools_scm
+ (substitute* "pyproject.toml"
+ ((">= 2.0.0, <3") ">= 2.0.0"))))
+ (replace 'build
+ (lambda _
+ ;; ZIP does not support timestamps before 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))))
+ (replace 'install
+ (lambda _
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl)))))))
+ (native-inputs
+ (list python-pypa-build python-pytest python-setuptools python-setuptools-scm))
(propagated-inputs
(list python-six python-frozendict python-simplejson))
(home-page "https://github.com/matrix-org/python-canonicaljson")