aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-10-27 16:33:30 +0800
committerLudovic Courtès <ludo@gnu.org>2022-11-06 00:37:06 +0100
commita60dc46c2bb5de196858594b72b00d5f86ca7e98 (patch)
tree3e186b4263757db78fbc89763c88e4f694711425
parent1bb3a3ea4efb607b48988bed2b2b949406e12623 (diff)
downloadguix-a60dc46c2bb5de196858594b72b00d5f86ca7e98.tar
guix-a60dc46c2bb5de196858594b72b00d5f86ca7e98.tar.gz
gnu: libcxx+libcxxabi: Use G-expressions.
* gnu/packages/llvm.scm (libcxx+libcxxabi-6)[arguments]: Use G-expressions. <#:configure-flags>: Use "this-package-native-input". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/llvm.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 17c51ea6bb..324149116b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1677,27 +1677,29 @@ standard C++ library.")
(name "libcxx+libcxxabi")
(version (package-version libcxx-6))
(arguments
- `(#:configure-flags
- (list "-DLIBCXX_CXX_ABI=libcxxabi"
- (string-append "-DLIBCXX_CXX_ABI_INCLUDE_PATHS="
- (assoc-ref %build-inputs "libcxxabi")
- "/include"))
- #:phases
- (modify-phases (@ (guix build cmake-build-system) %standard-phases)
- (add-after 'set-paths 'adjust-CPLUS_INCLUDE_PATH
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gcc (assoc-ref inputs "gcc")))
- ;; Hide GCC's C++ headers so that they do not interfere with
- ;; the ones we are attempting to build.
- (setenv "CPLUS_INCLUDE_PATH"
- (string-join
- (delete (string-append gcc "/include/c++")
- (string-split (getenv "CPLUS_INCLUDE_PATH")
- #\:))
- ":"))
- (format #true
- "environment variable `CPLUS_INCLUDE_PATH' changed to ~a~%"
- (getenv "CPLUS_INCLUDE_PATH"))))))))
+ (list
+ #:configure-flags
+ #~(list "-DLIBCXX_CXX_ABI=libcxxabi"
+ (string-append "-DLIBCXX_CXX_ABI_INCLUDE_PATHS="
+ #$(this-package-native-input "libcxxabi")
+ "/include"))
+ #:phases
+ #~(modify-phases (@ (guix build cmake-build-system) %standard-phases)
+ (add-after 'set-paths 'adjust-CPLUS_INCLUDE_PATH
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref inputs "gcc")))
+ ;; Hide GCC's C++ headers so that they do not interfere with
+ ;; the ones we are attempting to build.
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append gcc "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":"))
+ (format
+ #true
+ "environment variable `CPLUS_INCLUDE_PATH' changed to ~a~%"
+ (getenv "CPLUS_INCLUDE_PATH"))))))))
(native-inputs
(list clang-6 llvm-6 libcxxabi-6))))