aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-02 11:54:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:03 -0400
commit03d4c76be30ef280209539f32ba573b4961a7641 (patch)
treed4fb95d0d2fd57844ca35ff3501907ee0ff7eff1
parent0d3fbfa347e5798cc066ed4a1bd1557c7858c4de (diff)
downloadguix-03d4c76be30ef280209539f32ba573b4961a7641.tar
guix-03d4c76be30ef280209539f32ba573b4961a7641.tar.gz
gnu: Add libx264-next.
* gnu/packages/video.scm (libx264-next): New variable.
-rw-r--r--gnu/packages/video.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cf260d71a3..c95bb02507 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -977,6 +977,27 @@ H.264 (MPEG-4 AVC) video streams.")
"file://extras/cl.h"
"See extras/cl.h in the distribution."))))))
+;;; TODO: Merge into libx264 on staging.
+(define-public libx264-next
+ ;; There are no tags in the repository, so we take the version number from
+ ;; the X264_BUILD variable defined in x264.h.
+ (let ((version "164")
+ (commit "b093bbe7d9bc642c8f24067cbdcc73bb43562eab")
+ (revision "0"))
+ (package
+ (inherit libx264)
+ (name "libx264")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://code.videolan.org/videolan/x264.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "095pv8y6fqjg8mdvsfk12d0jqgyhip536a6vxhzm7qz8hfp96qhq")))))))
+
(define-public mkvtoolnix
(package
(name "mkvtoolnix")