aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-03-20 21:11:00 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-03-20 22:33:18 +0800
commit32745b71e1a91cf59985dab473c1356297ee7bf1 (patch)
tree597ee7f270f02b376c1eddcc33ddc5f9463096be
parentc56739df6bdc4fc8c652fc4bb0b49d8d83a23dee (diff)
downloadguix-32745b71e1a91cf59985dab473c1356297ee7bf1.tar
guix-32745b71e1a91cf59985dab473c1356297ee7bf1.tar.gz
gnu: cdogs-sdl: Update to commit bab20313.
Fixes <https://bugs.gnu.org/30623>. * gnu/packages/games.scm (cdogs-sdl): Update to commit bab2031369b9ea2dbeb7eedbde10a43dd8ca83db. [source]: Use git-fetch.
-rw-r--r--gnu/packages/games.scm70
1 files changed, 37 insertions, 33 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a03e58b0ad..05b9a1e1c6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3539,42 +3539,46 @@ emerges from a sewer hole and pulls her below ground.")
license:cc-by-sa3.0)))))
(define-public cdogs-sdl
- (package
- (name "cdogs-sdl")
- (version "0.6.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/cxong/cdogs-sdl/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "08gbx6vqqir48xs6qdfa4kv70gj4j96wzs90pg7qldfasxz34ljm"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-DCDOGS_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/cdogs-sdl/"))))
- (inputs
- `(("mesa" ,mesa)
- ("sdl2" ,sdl2)
- ("sdl2-image" ,sdl2-image)
- ("sdl2-mixer" ,sdl2-mixer)))
- (home-page "https://cxong.github.io/cdogs-sdl/")
- (synopsis "Classic overhead run-and-gun game")
- (description "C-Dogs SDL is a classic overhead run-and-gun game,
+ ;; XXX: Use version 0.6.7 when it's available.
+ (let ((commit "bab2031369b9ea2dbeb7eedbde10a43dd8ca83db")
+ (revision "1"))
+ (package
+ (name "cdogs-sdl")
+ (version (git-version "0.6.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cxong/cdogs-sdl.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09sfqhrrffhvxbhigvrxfmai52w01w3f9kjmixjhqvqlkhn77c9n"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCDOGS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cdogs-sdl/"))))
+ (inputs
+ `(("mesa" ,mesa)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-mixer" ,sdl2-mixer)))
+ (home-page "https://cxong.github.io/cdogs-sdl/")
+ (synopsis "Classic overhead run-and-gun game")
+ (description "C-Dogs SDL is a classic overhead run-and-gun game,
supporting up to 4 players in co-op and deathmatch modes. Customize your
player, choose from many weapons, and blast, slide and slash your way through
over 100 user-created campaigns.")
- ;; GPLv2+ for code (includes files under BSD-2 and BSD-3),
- ;; CC0/CC-BY/CC-BY-SA for assets.
- (license (list license:gpl2+
- license:bsd-2
- license:bsd-3
- license:cc0
- license:cc-by3.0
- license:cc-by-sa3.0))))
+ ;; GPLv2+ for code (includes files under BSD-2 and BSD-3),
+ ;; CC0/CC-BY/CC-BY-SA for assets.
+ (license (list license:gpl2+
+ license:bsd-2
+ license:bsd-3
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0)))))
(define-public kiki
(package