aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-22 14:30:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-22 14:40:40 +0100
commit069d0b7f913c878559cf519715436423cb03a389 (patch)
treefa153f08a7ede441cf04f3c146b90b9d82d62c17
parent0e4d067f9eb5c493270930b95e4d5c9dd940657f (diff)
downloadguix-069d0b7f913c878559cf519715436423cb03a389.tar
guix-069d0b7f913c878559cf519715436423cb03a389.tar.gz
gnu: nmap: Update to 7.70.
* gnu/packages/admin.scm (nmap): Update to 7.70. [source](snippet): End on #t. [inputs]: Add ZLIB.
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6ed1c322fa..6a7bed3892 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1736,30 +1736,34 @@ done with the @code{auditctl} utility.")
(define-public nmap
(package
(name "nmap")
- (version "7.60")
+ (version "7.70")
(source (origin
(method url-fetch)
(uri (string-append "https://nmap.org/dist/nmap-" version
".tar.bz2"))
(sha256
(base32
- "08bga42ipymmbxd7wy4x5sl26c0ir1fm3n9rc6nqmhx69z66wyd8"))
+ "063fg8adx23l4irrh5kn57hsmi1xvjkar4vm4k6g94ppan4hcyw4"))
(modules '((guix build utils)))
(snippet
- '(map delete-file-recursively
- ;; Remove bundled lua, pcap, and pcre libraries.
- ;; FIXME: Remove bundled liblinear once packaged.
- '("liblua"
- "libpcap"
- "libpcre"
- ;; Remove pre-compiled binares.
- "mswin32")))))
+ '(begin
+ (map delete-file-recursively
+ ;; Remove bundled lua, pcap, and pcre libraries.
+ ;; FIXME: Remove bundled liblinear once packaged.
+ '("liblua"
+ "libpcap"
+ "libpcre"
+ ;; Remove pre-compiled binares.
+ "mswin32"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("openssl" ,openssl)
("libpcap" ,libpcap)
("pcre" ,pcre)
("lua" ,lua)
+ ("zlib" ,zlib) ;for NSE compression support
+
;; For 'ndiff'.
("python" ,python-2)))