aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-02-10 05:01:46 +0100
committerLeo Famulari <leo@famulari.name>2016-02-11 21:02:06 -0500
commitfc686f9a196a208b3d55a939d1b9062a6d046d7c (patch)
tree7f9b9f31800c327c6b2a808026be3880c93c92d0
parente57127fbe18de4e7cc79b9b2e9eac7b932a037b0 (diff)
downloadguix-fc686f9a196a208b3d55a939d1b9062a6d046d7c.tar
guix-fc686f9a196a208b3d55a939d1b9062a6d046d7c.tar.gz
gnu: Add btrfs-progs.
* gnu/packages/linux.scm (btrfs-progs): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/linux.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d5afaf94a3..79707d69bf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2467,3 +2468,38 @@ write access to exFAT devices.")
applications running on the Linux console. It allows users to select items
and copy/paste text in the console and in xterm.")
(license license:gpl2+)))
+
+(define-public btrfs-progs
+ (package
+ (name "btrfs-progs")
+ (version "4.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/linux/kernel/"
+ "people/kdave/btrfs-progs/"
+ "btrfs-progs-v" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jssv1ys4nw2jf7mkp58c19yspaa8ybf48fxsrhhp0683mzpr73p"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:parallel-tests? #f)) ; tests fail when run in parallel
+ (inputs `(("e2fsprogs" ,e2fsprogs)
+ ("libblkid" ,util-linux)
+ ("libuuid" ,util-linux)
+ ("zlib" ,zlib)
+ ("lzo" ,lzo)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("asciidoc" ,asciidoc)
+ ("xmlto" ,xmlto)
+ ;; For building documentation
+ ("libxml2" ,libxml2)
+ ("docbook-xml" ,docbook-xml)
+ ("docbook-xsl" ,docbook-xsl)))
+ (home-page "https://btrfs.wiki.kernel.org/")
+ (synopsis "Create and manage btrfs copy-on-write file systems")
+ (description "Btrfs is a copy-on-write (CoW) filesystem for Linux aimed at
+implementing advanced features while focusing on fault tolerance, repair and
+easy administration.")
+ (license license:gpl2+)))