aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-05-18 15:15:28 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-19 22:43:37 +0200
commit428adbc2c498252b1120da27944edc6558c04d06 (patch)
treef87d30bd1b82d1001acf626af1eb86c2db715b92
parentd282fee549c2bad9f413bada5f398aa220f84429 (diff)
downloadguix-428adbc2c498252b1120da27944edc6558c04d06.tar
guix-428adbc2c498252b1120da27944edc6558c04d06.tar.gz
gnu: xss-lock: New variable.
* gnu/packages/xdisorg.scm (xss-lock): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 0432411ab7..f42691b75d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1438,3 +1439,39 @@ with black color on a white background (colors are configurable on the
commandline).")
(home-page "https://www.joachim-breitner.de/projects#screen-message")
(license license:gpl2+)))
+
+(define-public xss-lock
+ ;; xss-lock does not seem to be maintained any longer, but the last commits
+ ;; fix important issues so we package them.
+ (let ((version "0.3.0")
+ (revision "1")
+ (commit "1e158fb20108058dbd62bd51d8e8c003c0a48717"))
+ (package
+ (name "xss-lock")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/raymonad/xss-lock.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10hx7k7ga8g08akwz8qrsvj8iqr5nd4siiva6sjx789jvf0sak7r"))))
+ (build-system cmake-build-system)
+ (inputs `(("glib" ,glib)
+ ("xcb-util" ,xcb-util)))
+ (native-inputs
+ `(("python-docutils" ,python-docutils)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f))
+ (synopsis "Use external screen locker on events")
+ (description "@code{xss-lock} listens to X signals to fire up a
+user-defined screensaver. In effect this allows to automatically lock the
+screen when closing a laptop lid or after a period of user inactivity (as set
+with @code{xset s TIMEOUT}). The notifier command, if specified, is executed
+first. Additionally, xss-lock uses the inhibition logic to lock the screen
+before the system goes to sleep.")
+ (home-page "https://bitbucket.org/raymonad/xss-lock")
+ (license license:expat))))