aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-02 11:54:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:03 -0400
commit0d3fbfa347e5798cc066ed4a1bd1557c7858c4de (patch)
tree47aa0b712854a73d94581e35996166651ff6b41c
parenta60dc46c2bb5de196858594b72b00d5f86ca7e98 (diff)
downloadguix-0d3fbfa347e5798cc066ed4a1bd1557c7858c4de.tar
guix-0d3fbfa347e5798cc066ed4a1bd1557c7858c4de.tar.gz
gnu: Add libvpx-next.
* gnu/packages/video.scm (libvpx-next): New variable.
-rw-r--r--gnu/packages/video.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2478b6bb90..cf260d71a3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2406,6 +2406,22 @@ To load this plugin, specify the following option when starting mpv:
(license license:bsd-3)
(home-page "https://www.webmproject.org/")))
+;;; TODO: Merge into libvpx on staging.
+(define-public libvpx-next
+ (package
+ (inherit libvpx)
+ (name "libvpx")
+ (version "1.12.0")
+ (source (origin
+ (inherit (package-source libvpx))
+ (uri (git-reference
+ (url "https://chromium.googlesource.com/webm/libvpx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))))))
+
(define-public youtube-dl
(package
(name "youtube-dl")