aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-10 18:44:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-10 18:44:00 +0100
commit835565777722d61f2b1e7a41df4ee74cd7fdb04e (patch)
tree1f07113032503c8fdf56b0c82414a2ff20d0cfa8
parentf1d38bfbe8fe30182887e992705b43d2f5427bf4 (diff)
downloadguix-835565777722d61f2b1e7a41df4ee74cd7fdb04e.tar
guix-835565777722d61f2b1e7a41df4ee74cd7fdb04e.tar.gz
gnu: emacs-adoc-mode: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-adoc-mode)[arguments]: Use G-expressions. Remove trailing #T from phases.
-rw-r--r--gnu/packages/emacs-xyz.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c0b0c96292..3dfa14edbf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25893,31 +25893,31 @@ and 'text viewing modes' respectively.")
"0bp2i66a9gp41r7nvbx8f4s334gd7lwjdxi3qw5yhgaav6gk3bkc"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; See: https://github.com/sensorflo/adoc-mode/issues/39.
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (let-syntax
- ((disable-tests
- (syntax-rules ()
- ((_ file ())
- (syntax-error "test names list must not be empty"))
- ((_ file (test-name ...))
- (substitute* file
- (((string-append "^\\(ert-deftest " test-name ".*") all)
- (string-append all "(skip-unless nil)\n")) ...)))))
- (disable-tests "test/adoc-mode-test.el"
- ("adoctest-test-tempo-delimited-blocks"
- "adoctest-test-tempo-macros"
- "adoctest-test-tempo-paragraphs"
- "adoctest-test-tempo-passthroug-macros"
- "adoctest-test-tempo-quotes")))
- #t)))
- #:tests? #t
- #:test-command '("emacs" "-Q" "-batch"
- "-l" "test/adoc-mode-test.el"
- "-f" "ert-run-tests-batch-and-exit")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; See: https://github.com/sensorflo/adoc-mode/issues/39.
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (let-syntax
+ ((disable-tests
+ (syntax-rules ()
+ ((_ file ())
+ (syntax-error "test names list must not be empty"))
+ ((_ file (test-name ...))
+ (substitute* file
+ (((string-append "^\\(ert-deftest " test-name ".*") all)
+ (string-append all "(skip-unless nil)\n")) ...)))))
+ (disable-tests "test/adoc-mode-test.el"
+ ("adoctest-test-tempo-delimited-blocks"
+ "adoctest-test-tempo-macros"
+ "adoctest-test-tempo-paragraphs"
+ "adoctest-test-tempo-passthroug-macros"
+ "adoctest-test-tempo-quotes"))))))
+ #:tests? #t
+ #:test-command '("emacs" "-Q" "-batch"
+ "-l" "test/adoc-mode-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs
(list emacs-markup-faces))
(home-page "https://github.com/sensorflo/adoc-mode/wiki")