aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-10 19:09:03 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-10 21:11:30 +0100
commit8186dc2224e44c7897fe8cd4715aae3aadab33ac (patch)
tree8899a9b703660e782b384d4db0ee6214a8408c52
parenta08f83ecdc3079de3422a1daa9f389937057744b (diff)
downloadguix-8186dc2224e44c7897fe8cd4715aae3aadab33ac.tar
guix-8186dc2224e44c7897fe8cd4715aae3aadab33ac.tar.gz
gnu: emacs-org-ql: Update to 0.7.
* gnu/packages/emacs-xyz.scm (emacs-org-ql): Update to 0.7. [arguments]<#:phases>: Remove unnecessary test fix.
-rw-r--r--gnu/packages/emacs-xyz.scm76
1 files changed, 34 insertions, 42 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5526170b57..15f5fe42b3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21513,49 +21513,41 @@ interactive commands and functions, such as @code{completing-read}.")
(license license:gpl3+)))
(define-public emacs-org-ql
- (let ((commit "29533525c39e0e243912bb3c807412e4bc3e804e")
- (revision "0"))
- (package
- (name "emacs-org-ql")
- (version (git-version "0.6.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alphapapa/org-ql")
- (commit commit)))
- (sha256
- (base32
- "01zc2mrlr197r0h2xjgzg88fy74lqbw0hv60jw08ihs0yw7n56y7"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:tests? #t
- #:test-command #~(list "buttercup" "-L" ".")
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'fix-test
- (lambda _
- (substitute* "tests/test-org-ql.el"
- (("can't be linked to") "can’t be linked to")))))))
- (native-inputs
- (list emacs-buttercup emacs-with-simulated-input))
- (propagated-inputs
- (list emacs-dash
- emacs-f
- emacs-helm
- emacs-helm-org
- emacs-org
- emacs-org-super-agenda
- emacs-ov
- emacs-peg
- emacs-s
- emacs-ts))
- (home-page "https://github.com/alphapapa/org-ql/")
- (synopsis "Query language for Org buffers")
- (description "This package provides a Lispy query language for Org
+ (package
+ (name "emacs-org-ql")
+ (version "0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/org-ql")
+ (commit version)))
+ (sha256
+ (base32
+ "092ckddjbs5d3h6w5x2zkpnm0qzcl00lb8q2656wa81q1kf6928k"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "buttercup" "-L" ".")))
+ (native-inputs
+ (list emacs-buttercup emacs-with-simulated-input))
+ (propagated-inputs
+ (list emacs-dash
+ emacs-f
+ emacs-helm
+ emacs-helm-org
+ emacs-org
+ emacs-org-super-agenda
+ emacs-ov
+ emacs-peg
+ emacs-s
+ emacs-ts))
+ (home-page "https://github.com/alphapapa/org-ql/")
+ (synopsis "Query language for Org buffers")
+ (description "This package provides a Lispy query language for Org
files, allowing for actions to be performed based on search criteria.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-bing-dict
(package