aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-03-10 21:43:20 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-10 21:43:20 +0100
commit7b4f47f0667265687693ac2be3043f1c7b878851 (patch)
tree50990330d0ce7125a2f2469c5d7986d599bb22a5
parent949160f521aac01a4edd57cbf8814cf40241ae58 (diff)
downloadguix-7b4f47f0667265687693ac2be3043f1c7b878851.tar
guix-7b4f47f0667265687693ac2be3043f1c7b878851.tar.gz
gnu: rasdaemon: Refactor package.
* gnu/packages/linux.scm (rasdaemon)[arguments]: Remove obsolete patch. Prefer wrap-program to brittle 'fix-dmidecode-and-modprobe phase. With commit 9367354a4e57506a7090143e423fa620f86eeed1, rasdaemon no longer creates /var/lib/rasdaemon at install time. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b08ee749f0..35d12c20d0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
;;; Copyright © 2022, 2023 Demis Balbach <db@minikn.xyz>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9668,21 +9669,15 @@ provides user-space tools for creating EROFS file systems.")
;; in EPERM during the install phase. Removing the offending
;; line lets sysconfdir correctly pick up DESTDIR.
(substitute* "configure.ac"
- (("^test .* sysconfdir=/etc\n$") ""))
- ;; Upstream tries to create /var/lib/rasdaemon at install time.
- ;; This results in EPERM on guix. Instead, the service should
- ;; create this at activation time.
- (substitute* "Makefile.am"
- (("^\\s*\\$\\(install_sh\\) -d .*@RASSTATEDIR@.*$") ""))))
- (add-after 'install 'fix-dmidecode-and-modprobe
- (lambda _
- (substitute* (string-append #$output "/sbin/ras-mc-ctl")
- (("find_prog \\(\"dmidecode\"\\).*$") (format #f "~s;~%" (string-append #$dmidecode "/sbin/dmidecode")))
- (("find_prog \\(\"modprobe\"\\).*$") (format #f "~s;~%" (string-append #$kmod "/bin/modprobe"))))))
+ (("^test .* sysconfdir=/etc\n$") ""))))
(add-after 'wrap 'wrap-rasdaemon
- (lambda _
- (wrap-program (string-append #$output "/sbin/ras-mc-ctl")
- `("PERL5LIB" ":" prefix ,(string-split (getenv "PERL5LIB") #\:))))))))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((path (map dirname
+ (list (search-input-file inputs "/sbin/dmidecode")
+ (search-input-file inputs "/bin/modprobe")))))
+ (wrap-program (string-append #$output "/sbin/ras-mc-ctl")
+ `("PATH" ":" prefix ,path)
+ `("PERL5LIB" ":" prefix ,(string-split (getenv "PERL5LIB") #\:)))))))))
(build-system gnu-build-system)
(home-page "https://github.com/mchehab/rasdaemon")
(synopsis "Platform Reliability, Availability, and Serviceability tools")