aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-08 16:08:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-09 15:10:13 +0200
commit7b1dd1e9eae20d7df5f1bcde6f7bb4906fc7ef9f (patch)
tree433b0458adeefdb13a7739e07344468fae56a27d
parent070c335a91d5c245f0360e12c794e9109f9faaf1 (diff)
downloadguix-7b1dd1e9eae20d7df5f1bcde6f7bb4906fc7ef9f.tar
guix-7b1dd1e9eae20d7df5f1bcde6f7bb4906fc7ef9f.tar.gz
gnu: make-openbios-package: Enable setting configure-flags.
* gnu/packages/firmware.scm (make-openbios-package)[arguments]: Adjust custom 'configure phase to apply configure-flags.
-rw-r--r--gnu/packages/firmware.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index a876aa727a..873ad02ae1 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -422,8 +422,9 @@ utilites used to process FCODE, OpenFirmware's byte code, consisting of:
(("TZ=UTC date \\+")
"TZ=UTC date --date=@1 +"))))
(replace 'configure
- (lambda _
- (invoke "./config/scripts/switch-arch" #$arch)))
+ (lambda* (#:key (configure-flags #~'()) #:allow-other-keys)
+ (apply invoke "./config/scripts/switch-arch" #$arch
+ configure-flags)))
(replace 'install
(lambda _
(let ((build-target