aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-19 11:09:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 19:09:01 +0100
commit5befcff66edb4d72ab8e713c81836fb8519ce3e6 (patch)
tree7ed84b16b655e4d7574301f4f949ac0a67b2d8a9
parentedce1efe5a6107f510ea1b652eb937d6a3faf9af (diff)
downloadguix-5befcff66edb4d72ab8e713c81836fb8519ce3e6.tar
guix-5befcff66edb4d72ab8e713c81836fb8519ce3e6.tar.gz
gnu: tlpui: Update to 1.5.0-6.
* gnu/packages/linux.scm (tlpui): Update to 1.5.0-6. [arguments]<#:phases>: Rename USE-TLP-INPUT into SET-ABSOLUTE-LOCATIONS to be more accurate. Also add a new phase to skip failing tests. [inputs]: Add LSBUTILS and PCIUTILS.
-rw-r--r--gnu/packages/linux.scm42
1 files changed, 32 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c025d6b4b..b08ee749f0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016, 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -7606,7 +7606,7 @@ every time the power supply source is changed.")
(define-public tlpui
(package
(name "tlpui")
- (version "1.5.0-1")
+ (version "1.5.0-6")
(source
(origin
(method git-fetch)
@@ -7615,7 +7615,7 @@ every time the power supply source is changed.")
(commit (string-append "tlpui-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "16a6x733szsggn23ns7bj3gpvb80675plh96v4llrz0s8p3h47pg"))))
+ (base32 "0zxiciafq1xmb047jlyhipkkj4vaiw4jzbx71f6xgx559dy96paq"))))
(build-system python-build-system)
(arguments
(list
@@ -7626,16 +7626,31 @@ every time the power supply source is changed.")
(lambda _
(substitute* "setup.py"
(("/usr/") ""))))
- (add-after 'unpack 'use-tlp-input
- ;; Hard-code tlp-stat filename to avoid propagating "tlp".
+ (add-after 'unpack 'set-absolute-locations
(lambda* (#:key inputs #:allow-other-keys)
- (let ((tlp-stat (search-input-file inputs "/bin/tlp-stat")))
+ (let ((defaults.conf
+ (search-input-file inputs "/share/tlp/defaults.conf"))
+ (lspci (search-input-file inputs "/sbin/lspci"))
+ (lsusb (search-input-file inputs "/bin/lsusb"))
+ (tlp-stat (search-input-file inputs "/bin/tlp-stat")))
(with-directory-excursion "tlpui"
(substitute* '("file.py" "settingshelper.py" "statui.py")
- (("which\\(\"tlp-stat\"\\)")
- (string-append "'" tlp-stat "'"))
(("\"tlp-stat\"")
- (string-append "'" tlp-stat "'")))))))
+ (string-append "'" tlp-stat "'"))
+ (("/usr/share/tlp/defaults.conf")
+ (string-append "'" defaults.conf "'")))
+ (substitute* "ui_config_objects/gtkusblist.py"
+ (("\"lsusb\"")
+ (string-append "'" lsusb "'")))
+ (substitute* "ui_config_objects/gtkpcilist.py"
+ (("\"lspci\"")
+ (string-append "'" lspci "'")))
+ ;; Settings check if various tlp executables, lspci and
+ ;; usbutils are available. Skip this phase since we know
+ ;; for sure they are (and it avoids patching each location).
+ (substitute* "settingshelper.py"
+ (("(command_exists = ).*" _ lead)
+ (string-append lead "True\n")))))))
(add-before 'check 'fix-home-directory
(lambda _
;; Tests fail with "Permission denied:
@@ -7646,6 +7661,13 @@ every time the power supply source is changed.")
;; Connection refused" and "Error: cannot read user
;; configuration from /etc/tlp.conf or /etc/default/tlp".
(delete 'sanity-check)
+ ;; Skip two failing tests (out of 10) about configuration file
+ ;; issues.
+ (add-before 'check 'skip-failing-tests
+ (lambda _
+ (substitute* "test/test_tlp_settings.py"
+ ((".*?windowxsize = 900.*") "")
+ ((".*?windowysize = 600.*") ""))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -7658,7 +7680,7 @@ every time the power supply source is changed.")
(native-inputs
(list `(,glib "bin") gobject-introspection python-discover))
(inputs
- (list gtk+ python-pygobject tlp))
+ (list gtk+ pciutils python-pygobject tlp usbutils))
(home-page "https://github.com/d4nj1/TLPUI")
(synopsis "User interface for TLP written in Python")
(description