aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-03-09 15:21:35 +0400
committerAndrew Tropin <andrew@trop.in>2023-03-09 15:31:10 +0400
commit070c335a91d5c245f0360e12c794e9109f9faaf1 (patch)
tree8ae4860cd1518195bafca09cf5565c38a277c55b
parentb4c64ddce44bb31332784c3f8e037bd565194604 (diff)
downloadguix-070c335a91d5c245f0360e12c794e9109f9faaf1.tar
guix-070c335a91d5c245f0360e12c794e9109f9faaf1.tar.gz
gnu: emacs-next-tree-sitter: Inherit from emacs-next-pgtk.
Make emacs with tree-sitter work on wayland as well. * gnu/packages/emacs.scm (emacs-next-tree-sitter): Inherit from emacs-next-pgtk, remove uneeded native-inputs, add synopsis and description. [source]: Use inherited patches.
-rw-r--r--gnu/packages/emacs.scm52
1 files changed, 24 insertions, 28 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9a5ec2ad0d..4e6587eef5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -420,52 +420,48 @@ languages.")
(modify-inputs (package-native-inputs emacs)
(prepend autoconf))))))
+(define-public emacs-next-pgtk
+ (package
+ (inherit emacs-next)
+ (name "emacs-next-pgtk")
+ (source
+ (origin
+ (inherit (package-source emacs-next))
+ (patches
+ (append (search-patches "emacs-pgtk-super-key-fix.patch")
+ (origin-patches (package-source emacs-next))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:configure-flags flags #~'())
+ #~(cons* "--with-pgtk" #$flags))))
+ (synopsis "Emacs text editor with @code{pgtk} support")
+ (description "This Emacs build implements graphical UI purely in terms of
+GTK.")))
+
(define-public emacs-next-tree-sitter
(let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
(revision "0"))
(package
- (inherit emacs)
+ (inherit emacs-next-pgtk)
(name "emacs-next-tree-sitter")
(version (git-version "30.0.50" revision commit))
(source
(origin
- (inherit (package-source emacs))
+ (inherit (package-source emacs-next-pgtk))
(method git-fetch)
(uri (git-reference
(url "https://git.savannah.gnu.org/git/emacs.git/")
(commit commit)))
(file-name (git-file-name name version))
- ;; emacs-source-date-epoch.patch is no longer necessary
- (patches (search-patches "emacs-exec-path.patch"
- "emacs-fix-scheme-indent-function.patch"
- "emacs-native-comp-driver-options.patch"))
(sha256
(base32
"1akq6dbllwwqwx21wnwnv6aax1nsi2ypbd7j3i79sw62s3gf399z"))))
(inputs
- (modify-inputs (package-inputs emacs)
+ (modify-inputs (package-inputs emacs-next-pgtk)
(prepend sqlite tree-sitter)))
- (native-inputs
- (modify-inputs (package-native-inputs emacs)
- (prepend autoconf))))))
-
-(define-public emacs-next-pgtk
- (package
- (inherit emacs-next)
- (name "emacs-next-pgtk")
- (source
- (origin
- (inherit (package-source emacs-next))
- (patches
- (append (search-patches "emacs-pgtk-super-key-fix.patch")
- (origin-patches (package-source emacs-next))))))
- (arguments
- (substitute-keyword-arguments (package-arguments emacs-next)
- ((#:configure-flags flags #~'())
- #~(cons* "--with-pgtk" #$flags))))
- (synopsis "Emacs text editor with @code{pgtk} support")
- (description "This Emacs build implements graphical UI purely in terms of
-GTK.")))
+ (synopsis "Emacs text editor with @code{pgtk} and @code{tree-sitter} support")
+ (description "This Emacs build implements graphical UI purely in terms
+of GTK and supports tree-sitter."))))
(define-public emacs-minimal
;; This is the version that you should use as an input to packages that just