aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 00:17:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 18:36:02 +0200
commit61497aa481f38e04030610e8bb4b7860030fdb52 (patch)
tree6271fdbbaab1427016d822537d51fa47aff55343
parent7b725203a61c26927cfb61a8061c351370fd3762 (diff)
downloadguix-61497aa481f38e04030610e8bb4b7860030fdb52.tar
guix-61497aa481f38e04030610e8bb4b7860030fdb52.tar.gz
gnu: python-trezor: Update to 0.11.3.
* gnu/packages/finance.scm (python-trezor): Update to 0.11.3.
-rw-r--r--gnu/packages/finance.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 328fd13a9d..5b95bcb704 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -742,14 +742,14 @@ Ledger Blue/Nano S.")
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.11.2")
+ (version "0.11.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor" version))
(sha256
(base32
- "1f0zfki12mnhidkfxpx2lpq1xim8f35i2d64bx9lf4m26xxv9x56"))))
+ "0211m027vlvyqy83kwbjjjxalb04xgf1klv0h0y0f0yhj07516n7"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -770,12 +770,13 @@ Ledger Blue/Nano S.")
("python-requests" ,python-requests)
("python-typing-extensions" ,python-typing-extensions)))
(native-inputs
- `(("protobuf" ,protobuf) ; Tests
- ("python-black" ,python-black) ; Tests
- ("python-protobuf" ,python-protobuf) ; Tests
- ("python-isort" ,python-isort) ; Tests
- ("python-pyqt" ,python-pyqt) ; Tests
- ("python-pytest" ,python-pytest))) ; Tests
+ ;; For tests.
+ `(("protobuf" ,protobuf)
+ ("python-black" ,python-black)
+ ("python-protobuf" ,python-protobuf)
+ ("python-isort" ,python-isort)
+ ("python-pyqt" ,python-pyqt)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/trezor/python-trezor")
(synopsis "Python library for communicating with TREZOR Hardware Wallet")
(description "@code{trezor} is a Python library for communicating with